Mounted Volumes not displaying

With version 12.5 when I mount a veracrypt volume to a drive letter it does not show up under Directory Opus. in either the folder tree or file list unless I type the mounted volume drive letter into the address bar.

Screen shot attached.

Does it appear if you push F5 to refresh This PC?

Are you mounting it as a removable drive or as a fixed drive? (It's an option in VeraCrypt.)

If you open an Explorer window showing This PC before mounting the drive, does it see the drive without needing a refresh, or does it do the same as Opus?

Make sure you have not run the whole Opus process UAC-elevated as administrator, as that will block drive insert/eject events from reaching Opus. (Using Admin Mode and UAC within Opus is fine, but running the whole dopus.exe process elevated will cause various problems, unless the whole shell is also elevated, or UAC is disabled entirely.)

I must have been in an elevated state. After a reboot the issue is no longer there.
Today is backup day where I back up my system to encrypted drives. I will mount and dismount veracrypt volumes a couple dozen times.
I mount some as removable drives but most are mounted as fixed.
Explorer showed the mounted drives but DO did not even after an F5 refresh. I had to manually the drive letter into DO in other for DO to show it.

I do not run DO in an elevated state normally. Although my user is an administrator (not THE administrator).
It seems it was a clitch as I am able to see the mounted volumes as I should.

Thank you for your quick reply