GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Movie plugin no longer playing FLAC files

The catch-all view plays FLAC, but calls Windows Media Player to do it. The volume gets reset each time to click on a file, which can be annoying and disruptive.

I had changed the default player to the Movie plugin by adding .FLAC to the extension list and moving the Movie plugin to the top of the list.

This worked fine until 12.17 installed. Now it's back to WMP.

Any idea how I can get back to the Movie plugin playing FLAC files? WMP plays them fine outside of DO.

The movie plugin itself did not change in 12.17 (or for a long time), so something has probably messed up the splitters/codecs on your system, or the way they are configured in the registry.

Note that the Movie plugin uses 64-bit components while Windows Media Player defaults to the 32-bit version, which may account for the difference between the two.

Assigning FLAC to Windows Media Player is sometimes enough to make it repair the registry details (for both 32-bit and 64-bit apps).

We could add a setting for when WMP is being used to half the volume fairly easily. I think most things play at full volume by default, but it can be controlled (at least the ActiveX version of WMP; I'm not sure the same is true for the Preview Handler version).


I had done my homework and found the guide you published giving instructions on how to reset file associations. I had changed the default program to Windows Media Player and it didn't make a difference.

Went back and double-checked - there was actually a VLC update the same day as the DO update, and that's what likely caused the problem.

Looking closely as I open the viewer window, I now see the Movie plugin open for a split second displaying the toolbar, then the background flashes white and WMP opens. I've confirmed that the catch-all is opening it as when I remove disable the catch-all, only the track thumbnail is displayed. If I right-click on the thumbnail and choose "Use Plugin" and select "Movie", I get the same white flash and the thumbnail is displayed again.

I suspect there is an issue somewhere with the Movie plugin. Any idea how to further troubleshoot this? Unfortunately it works fine on my other machine, but this is the one I do all my audio work on :frowning:

What you're seeing is the Movie plugin try to open the file, but fail (due to the splitters/codecs not handling it), and then Opus falls back on another plugin.

It's not an issue with the Movie plugin itself (which hasn't changed between when it worked and when it stopped working) but with the 64-bit FLAC splitter/codec or corresponding registry data on the system.

It's possible VLC modified the registry when it was installed. It's been known to in the past.

Note that on a vanilla Windows 10 install, testing with Opus 12.14, FLAC does not play by default in the Movie player. For that to have worked, you must have installed something extra (something that installed a 64-bit FLAC splitter/codec). If you can work out what that was, then reinstalling it would probably fix the problem. (Another possibility is a recent Windows Update broke something. The test machine I'm using is fairly up to date, so I haven't tested whether it worked out of the box on older versions of Windows.)

You were right - good catch. Installing K-Lite Codec Pack Standard totally solved the problem without having to change any other settings. Hopefully this will help anyone else struggling with this or a similar problem. I have K-Lite installed on all the machines I do video on, but use this one primarily for music so it wasn't installed.

1 Like

I'm currently in this boat and doing the "K-Lite Codec Pack Standard" install didn't help =\ my default Movie app is set to MPC-HC but I haven't tried any regedit yet

You shouldn't need to use regedit to get this fixed. Actually I've never had to use regedit to fix a problem at all.

Double-check this and if it doesn't fix it I'm sure Leo will step in and figure it out.

Open a lister, choose Preferences from the Settings pull-down. Scroll down to Plugins under the Viewer category on the left. Here you can change not only which plugins are active, but also the order they are called.

Here is the order that works for me: Audio Tags, Movie, Raw Digital Camera, Animated GIF, JPEG 2000, PCX, Targa, WebP, HEIF, Wav, WMA, ActiveX, Multi-view, Text File Thumbnails, Text.

Make sure all are active except Multi-view.

I use this every day - once you get it right, it's totally solid. I've also created a button that toggles both the player and view windows together, so you can click on a track, click the button, have it play in the pane that opens on the top right, and view the attributes of the track on the bottom right. Click the button again and the panes both close. Easy button to create...

1 Like

@rbaer - KING! I copied your order (after the mpc install) and videos are now playing. Thanks!