Movie thumbnails always show first frame


Recently, since update to latest 12.29, Thumbnail generation for movies stopped working well. The thumbnail will always be the first frame regardless of settings for Maximum time per thumbnail and skipping black frames.
I use K-lite codec pack. Tried uninstall and reinstall latest version, and tried different settings in decoder tweak tool. Nothing seems to stop it selecting the first frame as the thumbnail.
Any ideas of things to try?

Is it the same frame that File Explorer's thumbnails are showing?

No. Explorer generated thumbs are further in, whether generated in Explorer itself, or dopus with generate thumbnails unchecked.

Thanks. That indicates the Opus Movie plugin is still the thing generating the thumbnails (which is fairly unusual these days, at least with Windows out of the box; likely means some extra codecs have been installed).

It will only keep trying to seek ahead and look for new frames for a short amount of time, to avoid thumbnailing taking too long. It's possible that timeout is being reached.

I don't think we changed the Movie plugin or anything related in 12.29, but it's possible the external codecs that are being used have changed and are influencing things.

If the thumbnails you see in File Explorer are better, disabling the Movie plugin, or just its thumbnails, would be best. Beyond that, the answer is probably in the codecs, but those can be complicated and difficult to diagnose, unless you know you've installed/updated some codecs or a codec pack (or video-related software that might do the same) recently.