GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Multi-part RAR files, can only open first part


#1

Hi there,

at home, I have quite a few archive-files to handle.

So I have a little problem to solve:

DOpus wants you (I guess) to always select the first archive-file of a set (with the built-in zip-handler). The problem is that in some folders I sometimes have more than 50 parts of the archive. Searching for the first file can be very annoying sometimes :confused:

So if I click for example on part 6 of 50 to open, DOpus does not recognize the full archive-set and I get the attached error-message.

Is is possible to solve that problem (so that I click on any archive-part I want)?

Regards



#2

This won't be changing, sorry.

Note that when you open something other than the first part in most programs, you get a truncated version of the archive which only contains the files from that part onwards, skipping anything in previous parts. That is such a problem that we made Opus prevent you from doing it by mistake.


#3

Not a real problem for me, thank your for the information.

I just want to note that WinRAR actually can handle this situation easily.


#4

Are you sure about that? Because it does the thing I described above when I try here using WinRAR 5.0:


With both WinRAR and Opus, you have to double-click the first part of the archive to get the right result.

The difference is what happens if you double-click another part. Opus will give you an error message while WinRAR will happily open the archive with anything from the earlier parts truncated.


#5

Checked it with a multi-part-archive that contains 102 parts. I said "unpack" to part 60 via context-menu. No problem - and I never had a problem with this since V4.


#6

Sorry for double-post, but I really don't know which settings you use. Looks wierd to me. WinRAR opens the whole archive for me, not just part X or Y as seen on your screen...
And I use stock settings, nothing is changed witin WinRar


#7

I'm talking about double-clicking the files, or using Open With, to open them in WinRAR (like they're being opened in Opus in the root post), not the right-click Extract option.

(Turns out WinRAR opens the truncated archive in one case, and finds the first part automatically in the other case. IMO, that is more confusing than consistently requiring the first part to be used in both cases.)


#8

I checked again:

No matter how I want to open a multi-part-archive (right-click-extract, double-click, open-with), there is 0 problem with it. It finds the whole archive and / or extracts it.

I just disabled the internal zip-handler, with this "problem" this function is useless for me. But despite this, DOpus is awesome!


#9

That's not how any version of WinRAR has ever worked for me. I've tried 4.x and 5.x today, both with default settings and split archives they created themselves, and they always truncate when opening (not extracting) a later part.

Make sure there are some small files at the start of the archive so that the part you open doesn't start with part of a large file that spans from the start to the opened part. (Although even then, WinRAR adds some arrows after the filename to indicate parts of the file are in previous parts of the archive).

TBH, I don't really understand why this is such a problem either way, especially with modern RAR split archives that have the .part01.rar as the first file and never make you hunt for it like the old .rXX naming convention.


#10

One thought: It's possible that WinRAR handles solid split archives differently to non-solid ones. I've only tried with non-solid since that's the default that WinRAR creates.