Multiview Plugin Issues

I'm running the latest version of DOpus under WinXP Pro Sp-2 (fully patched) and am using the Stellent viewers that ship with X1 (latest build). I find that often selecting one file in a folder, vieweing it in the viewing pane and then selecting a second file (of the same format in the same folder) results in the viewing pane displaying hex. I can get around this one of two ways - by either closing the viewing pane and then reopening it or by opening the file in the Viewer ("Shows currently selected pictures"). In both cases, the file displays perfectly. This seems to be a bug with the viewing pane itself. I don't have this problem viewing files using the same libraries within X1, neither did I see this issue when running the latest trial version of QuickViewPlus (9).

I've seen this behaviour with pdf files, word docs (2003 and older formats), excel files, (2003 and older), Powerpoint files (2003 and older), and Star Office 8 Write formats.

Notes: 1. This behaviour doesn't affect all files - often I can view a number of files of the same format in the same folder, but there will be one or more that will not display in the viewing pane in that viewing pane "session" - the above "fixes" work; 2. this problem predates the installation of the QVP trial. 3. switching for the X1 libraries to the QVP libraries, unloading DOpus and reloading it doesn't result in any change in this behaviour.

Here are three screenshots showing the second "fix" (invoking the viewer):

Have you removed those extensions from the ActiveX plugin? If not then the ActiveX plugin may be handling the files rather than the MultiView plugin.

(To find out which one it is, load one of the files successfully and then right-click the viewer where it says the type of file; one of the last items in the menu will be the name of the plugin that is being used.)

Knowing this won't solve the problem, of course, but the solution may be different depending on which plugin is going wrong.

Hi Nudel,

Thanks for your response (and for moving this thread to the correct forum - oops! I tell my students to READ the instructions on exams and look at what happens when the instructor is similarly tasked with reading...). I have removed those extensions from the list handled by the active-x plug-in, and have confirmed that they are being handled by the MultiView plug-in via the context menu.

I just tried something that hadn't occurred to me to try before - I successfully displayed a ppt file in the viewer pane, then selected another from the same folder and it presented me with hex. I then right clicked the viewer pane (still displaying hex) and noted that it was being handled as a text file, then I selected the "use plugin" option and chose "multiview" and it immediately displayed properly in the viewer pane. This works with pdfs as well. What's weird about the pdfs that in the first folder that I tried this on, all of the pdfs were created from ppt via Scansoft PDF Converter 4 during the same session and yet some displayed immediately while others required me to right click the viewer pane and do the above. The only difference/added step is that the context menu shows the text plugin as being used and yet the multiview plugin is already selected when I click on "use plugin". I have to select another plugin (I went with text) and then repeat the process, selecting Mulitview and it viewed no problem. I went on to confrim that this works on an assortment of pdfs, created in different apps and at different times, I just thought it noteworthy that in the folder that I tried initially I was able to replicate this even though the files were all from the same source/session...

Thanks again,


PS I've tried 6 different sets of the Stellent viewers (2003 - QuickView Plus 8, 2006 - QuickView Plus 9, 2004 - DiskJockey 2000 Pro, 2005 - DiskJockey File Viewer DE, 2005 - Yahoo Desktop Search (archived), and 2006 - X1), so it's not the particular flavour of Stellent viewers that's the problem - they also work fine in their respective apps (only one I couldn't test this under was YDS as I haven't got it installed any longer).

See this thread

Thanks for the link Ken - I missed that thread yesterday. I note that Stellent viewers below 8.1.0.xxxx work (Yahoo Deskotp Search and QuickViewPlus 8) and that those above do not (X1 and QuickViewPlus 9). I don't know why this wasn't working for me yesterday - as noted in my previous post, I tried all of these different versions. I can only guess that in my haste I missed shutting down and restarting DOpus to make sure that the new viewers were loaded. I don't always have to do this, but every so often it's necessary.