Need help preventing dialog box popping up

Sorry, the tittle isn't very good.

I often move and copy lots of folders. The problem I am having is that it seems that every time a new folder operation starts the move/copy dialog pops up again. This makes it very hard to use opus.

There is an unattended option which works great, but I'm not sure what settings to use.

I want it to be silent except for when there is a conflict and I want it to pop up and tell me what the conflict is. I hope that makes sense. I want the move/copy to not pop up and block my work in opus unless there is a conflict.

What is the best way to do this?

It shouldn't normally, if it's a simple move/copy all done at once.

Are there some details you've missed out? Are you using the copy queue? Or extracting lots of archives rather than a simple copy? Or using a custom command or script to do something unusual?

I wrote a script that recursively digs through all selected folder and moves folder based on name to correct locations and also moves specific files to specific locations.

So when one transfer completes the next transfer pops up another transfer window.

Perhaps there is something I could put in the java script to make this better??? I could post the code if you need it. (fair warning, it's a bit sloppy)

edit: if I post the code is there a code option or do I just paste it as plain text?

That's a big detail to omit. :smiley:

The script is starting a sequence of separate and unrelated moves/copies, as far as Opus is concerned.

You might be able to use cmd.SetProgress(...) on the command object to make each operation share a single progress object/dialog, but it looks like it's the same command object used each time, so that probably won't make a difference.

Adding @noprogress to the commands would suppress the progress dialogs entirely, but then you can't know when things are finished unless you add some other progress indication to the script.

An easy way to avoid the problem, without having to change the script at all, is to turn on these options under Preferences / File Operations / Progress Indicators:

  • Minimize progress indicators
  • Display the jobs bar automatically when starting a new job

Then no progress dialogs will open at all, just small buttons at the bottom of the main window which show a progress bar, a bit like how the Windows taskbar works. You can click on the buttons to open the progress dialogs if you need to see more detail about what's happening, but they won't interrupt you when they start anymore. (You'll still see error/retry prompts if there's a problem during the move/copy.)

Thanks this seems to work perfectly. I get a giant green arrow that points down to the progress bar. I tried disabling "slide animation when qued job begins" but that doesn't seem to be the correct option, because it still happens.
Can I disable the green arrow or change it to something smaller?

found this Cannot hide Jobs bar arrow which lead me to!Documents/Prefs/Advanced.htm

The fix is "set "jobsbar_no_arrow" to True"