Network drive not refreshing after hibernation (Parallels / Win 11 ARM)


in Parallels, it is possible to connect Mac folders (such as the Mac Downloads folder) to the Windows 11 ARM VM. The Mac Downloads folder (originally APFS) will then appear as a network drive (PrlSF) within Windows. I believe Samba is used, but I'm NOT sure. I could ask if that is important.

In any case, when I make changes in the APFS folder that is mapped to network drive W: in the VM, then those changes show up immediately in Windows Explorer, but not in DOpus (x86).

Is it possible to fix this?

Thank you!

See here for how to troubleshoot that kind of thing:

Thanks, I found the reason: It was NOT a difference between DOpus and Explorer.
Rather, both DO and Explorer are able to detect changes, but after resuming from hibernation, the connection seems to get lost. A parallels issue probably.

Thank you.

The reason I thought it was DOpus was that Explorer worked, but that was simply because it was freshly launched. Thus your tip with restarting DOpus worked. I didn't even expect that because I had never seen it work (probably because I had always hibernated at least once before operating in any such connected drive.

1 Like

Just theoretically, would DOpus be able to "reconnect" without restarting the whole program, after some trigger (such as resume from hibernation).

Possibly, but if the OS itself (or fileserver at the other end) is not maintaining and reestablishing those notification handles correctly after a resume from hibernation, it might be hard for us to detect it and do better. It's possible the server still won't work immediately after hibernation, and would require some kind of delay, which would be hard to test and might vary by server/network/etc.

It's something the OS should take care of, really. I think the best we could do would be to let you click a button which drops and re-creates all the change-notification handles.

I have submitted a support request at parallels to see what they say. I will report here.

If anybody can reproduce this problem on a non-exotic setup, please tell. Though I cannot really tell much about the protocols and I don't have time at the moment to look into this, sorry.

Parallles Support said it was a Windows issue and provided the following two links which might be of interest to readers and developers here: