No App for Opening a video or JPEG available in DO but in Explorer

DO13, when double clicking a mp4 vid, I get this error message:
it says similar: "The given procedure was not found".

When repeating this in Windows Explorer, the video opens as expected, the default Windows 11 media player.

Same happens with jpg files, Explorer does open the Windows Photo App:

When this popup shows up, after closing it I get a new one:
The German text read like: "There is not app assigned to execute this action. Please install an app...."

So, basically all above files can be opened in Windows Explorer but not in DO13.1.1.
FWIW, the lister's context menu item "Open With" shows Media Player or the Photo App as suggestion.

Open With > Choose Default usually fixes things like that.

Thanks Leo for your reply! Unfortunately this does not fix it :frowning:

See video below, sorry for the German UI, but I guess you see the steps I've taken.

I've already started a first try to fix the video assignment, this only worked partly. Still seeing the error popup but afterwards the video player starts nevertheless. Fixing the jpeg assignment did not succeed either.

Both tries included to set the default app permanently, as seen in the Windows popup.

Does it work if you choose a desktop app rather than a Microsoft Store app? Launching Store apps has a lot of extra complexity, so it'd be good to know if that's involved or if it's something else.

Check that no compatibility settings have been turned on for dopus.exe, as that could break launching Store apps:

I've now installed the Photos-Legacy, the old Win10 photo application (from Windows 11 store) assigned .jpg and .jpeg file types and re-tried - to no avail either.

Again, when opening a .jpg file, I get the error as shown above. Even when assigning Photos-Legay app, using context menu "Open With", the result is the same.

Still Windows Explorer does not show this error and opens the file immediately - now with Photos-Legacy.

Edit: No compatibility settings are set für DO exe.

You could remove any association and start over:

  • Create an empty file dummy.exe
  • Assign .jpg to dummy.exe via "Open with"
  • Delete dummy.exe and reboot

Does it open from within Opus via the context menu?

Unfortunately not, neither double clicking nor using context menu "Open" does the job!

Will try this later on...

So, I've now used Windows Explorer itself and its context menu "Open With" and pointed to the Photo-Legacy as target app.

This worked in Explorer flawlessly and since then in DO, too! No matter if I double click or use context menu "Open".