GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Norton Internet Security 21 "Scan Now"


#21

Could someone kindly post the step-by-step to add this command to the context menu for a newb like me? Thanks!


#22

I've just installed version 11 beta, but it looks like the instructions are unchanged from version 10 - so here goes:

  1. From the Settings menu, select File Types
  2. Double-click on the second entry "(NONE) All files and folders"
  3. Click the Context Menu tab
  4. Click the New button
  5. Enter a name for your Action, e.g. Norton Internet Security Scan Now
  6. For Type, select "Run an Opus function (not supported in Explorer)"
  7. For Function, select "Standard Function (Opus or external)"
  8. Browse to the location of navw32.exe, select the file and click Open
  9. Add {F} to the end of the command. For the current version of NIS I have the following (the quotes are required):
    "C:\Program Files (x86)\Norton Internet Security\Engine\21.1.0.18\navw32.exe" {F}
    
  10. Click OK
  11. Click OK again
  12. Click Close (to close the Files Types dialog)

When you right-click on a file or folder you should see your custom action in the list (probably at the bottom). Select it and your folder or files should be scanned.

Some folder and file-names will cause the scan to fail. Aside from temporarily changing the file/folder name I'm not sure if there's a good solution to this.


#23

I just used the great, detailed instructions above with Norton Internet Security version 21.0.1.3, after having uninstalled the McAfee Kive Safe that came pre-installed. Both of these programs would not show right-click (context) scan capabilities in DOPUS but would show right-click capabilities in Windows explorer.

After following the instructions from "lancea", I now have the right-click Norton capabilities that I had in version 20!

Thank you.

I am using Windows 8.1, 64 bit. I doi not, as yet, have the 8.1 update installed.


#24

Hi Robert. That's great to know, thank you. It stopped working for me about a week ago after Norton released a bigger patch than usual. I simply had to change the sub-folder that referred to the new version number.


#25

Hi lancea,

Actually, you have solved a problem I had - twice. This post you did about it stopping to work made me look to see if Norton had updated. It had, and that was why Norton had stopped working for me. Now I can quit pulling my hair out...

Thanks again!


#26

Good one. Always nice to be able to give a little something back, especially when Directory Opus is such a productivity booster.


#27

Many thanks, @lancea, for these instructions. Very handy.


#28

Thank you. It's good that Norton don't change the folder very often, despite some of the LiveUpdates being very large. As you've obviously worked out (but it may be useful to others), the command for the current update of NIS is this:

"C:\Program Files (x86)\Norton Internet Security\Engine\21.3.0.12\navw32.exe" {F}

#29

Thanks again, @Lancea.

=> The line with the engine number needs to be edited regularly: it is now 21.4.0.13.

I wish Directory Opus would do it for us!


#30

We wish Norton didn't intentionally disable their shell extension outside of Explorer (and that they didn't include a changing version number in their exe path).

These problems are of Norton's making and there is no good way for Opus to solve them. Please complain to Norton.


#31

Fair enough, this is indeed a Norton issue.


#32

Symantec are changing the names of their products (ever so slightly). The command for the BETA version of Norton Security 22.0.0.79 is this:

"C:\Program Files (x86)\Norton Security\Engine\22.0.0.79\navw32.exe" {F}

#33

I asked on the Norton Forum "GP Software Directory Opus users wish Norton didn't intentionally disable their shell extension outside of Explorer (and that they didn't include a changing version number in their exe path)."

The reply I got was: "Norton is not disabling the function in your program. Other file explorer programs also are not supported. I believe it has to do with the way these programs have not adopted the latest Windows APIs for that functionality. Others will correct me if i am wrong. Norton has done so to be able to support Windows Explorer."

:neutral_face:


#34

I wish the programmers of Directory Opus and those of Norton Internet Security would talk directly with each other on this matter :frowning:


#35

All the information we could give Norton is already in a thread on their forum: community.norton.com/t5/Norton-I ... 85#M245399

Opus is calling their shell extension, to ask if it wants to add any items to the menu. Their shell extension isn't adding any items to the menu. Why is impossible for us to tell, but should be very easy for them to work out, since they have the code to their shell extension and would just need to run it inside Opus (or any of the many other programs their shell extension fails to work in!) with a debugger attached. It would take them 10 minutes to do.

Please also link your account if you're going to keep bumping this thread and asking us to "do more" when we've already done all we really can do and the ball is in Norton's court.


#36

By the way, if you open Notepad, then use File > Open from it and right-click a file there, does the missing Norton menu appear?


#37

In Directory Opus, I get the Norton right click menu after doing the changes as recommended in this threat.

If I open Notepad, use File > Open and right-click a file, there is no Norton menu.


#38

This thread has become a bit circular :slight_smile:...

If you go back to the beginning of the thread, and my early suggestions to Lancea on how to work around this whole mess, you'll find several things:

  • I had specifically called out the need to constantly have to update the path as Norton applied updates (yuck)... so as a workaround, the use of the {F} code via the NIS command line sure seems to mimic what the shell extension does closely enough, but it is indeed a PITA to maintain. And there's no path variable or anything else that you can reference to not have to manually update the path in your Opus customizations (bummer). I wonder if AV/AS vendors do this sort of thing on purpose so that malicious crap out there has that much little bit more of a harder time targeting any of their binaries - by having the path be obtuse and ever changing. Maybe a trick they learned from how they themselves used to have trouble beating up on other apps - anyone remember how later versions of Daemon Tools used to actually change its driver and process names between releases so that AV/AS software left them alone? LOL...

  • If you look back at my comments about the thread that hemm99 linked us to... or better yet just go to that thread yourself, you'll find the following response from a Norton forum admin named Mohan_G:

So... @Pierre-Philippe: from this statement, it certainly seems like the response that you got about it being a problem with other file managers not properly using Windows api's is either a total wild goose chase and BAD guidance from someone at Symantec who has no idea what they're talking about; or... that older comment from Mohan_G was incorrectly worded and could have been better stated by saying something like "Older methods of invoking shell extensions used by many (every?) third-Party Explorer Shells (like Total Commander, Turbo Navigator, Free Commander, PowerDesk, XYplorer, and Directory Opus) are no longer supported".

@Leo/Jon: is there even some newer method of invoking shell extensions that neither Opus or Notepad are using? Does that even hold water?

As an aside, since newer uses reading this thread are still tripping up over this even though I mentioned it specifically in my original posts, and Lancea implied it in his step by step directions - maybe the root post could be updated with Lanceas' own step by steps with some additional note about the path changing every time Norton updates NIS?


#39

And for what it's worth - I've raised yet another topic on the Symantec forum: community.norton.com/t5/Norton-I ... -p/1160772

...after discovering that another more recent thread than those listed previously here was also opened on the Symantec forum be someone who I imagine is our very own mrwul / opw62... :slight_smile:. But it was closed after inactivity with no more progress towards an explanation or resolve than any of the other threads.

Too bad the Symantec support rep (Vineeth) who apparently posted here earlier in the thread ever did anything to assist like he said he would... what a tease, on top of disappointment :frowning:.


#40

The File > Open dialog in Notepad is not just the same method for building the menu that Explorer uses, it is the same actual code for building the menu.

So it seems that Norton either have bug that depends on something very specific and unique to Explorer which is certainly not part of the Windows API, or they are intentionally doing a test to see if the host process is called "explorer.exe" (or something similar which would only match Explorer) and excluding them menu from anything else.

Norton cannot, with a straight face, claim they are doing their menu correctly and not intentionally excluding it from everything but Explorer if it does not work in any other program aside from Explorer, including Notepad which is part of Windows and which uses the standard File Open dialog which essentially is Explorer. That is ridiculous. It is up to them to fix this, or to explain why they have chosen to do things in this way, why they won't to listen to their users' complaints, and why they claim there are bugs in other software when it is clearly a problem or by-design issue in their own which they appear not to have investigated as they think blaming other people and saying they don't support anything but Explorer is acceptible.

We can't do anything about this, so I'm not going to spend any more time on this myself.