OneDrive Synced folders cannot detect content change

Hey, Leo,
I tried again today and read the prior guide thread deeper.
Yes you were right, no debug output was sent in my capturing.
But as long as I create one folder in C:\ root folder, all debugging logs flooded to debug view and the issue I complained was somehow cured (at least for quite one hour till now).
But still this is super strange and nearly happens everything I use this computer, maybe not from the beginning but after a while.
Do you have any idea why?

Sounds like the change notification system was stuck somewhere, but I don't know why that would happen, and the issue could be in Windows, Opus, or anywhere in-between (antivirus, filesystem).

I also have this problem but it only happens with synced system folders (documents, desktop...). Other folders in Onedrive are working. Any changes made inside Opus or with external tools are not reflected in the file view. I can see the changes immediately in windows explorer and other software. The weird thing is it is working sometimes and I can't find out why. Restarting Opus does not help. I tried to debug but as soon as I enable debug it is working!
I am on Windows 11, Onedrive and Onedrive for Business, latest Opus, but I have this problem for years now.

How much have you used the other software it seems to be working in? If it's that intermittent in Opus, and seems to start working again when nudged by something, then it may not be immediately apparent if the problem affects other things or just Opus, if the other things aren't being used often or for long.

Which antivirus is everyone using? Maybe there's a pattern there. We have seen a/v break change notification in the past. It's not a common cause, but if you're all using the same one then it might be worth investigating.

I just did some more tests. It seems that I was wrong, it also doesn't work in some folders outside the synced system folders, and it's working in some folders inside the system folders, so this is not a factor. I just found a folder where it's not working while the debug view is open. I don't see anything in the debug view until I press F5. It's also weird that in some folders file deletions are not reflected and in other folders they are.
I only use windows for AV.
I have never seen this happening outside Opus. But I tried changing files and compared Opus and other software. While Opus is not refreshing the file view windows exporer is. Even if the change was made with Opus.

Have you tried the standalone ChangeTest tool from the end of the Changes to folders are not being detected ?

Would be interesting to see if that also stops and starts receiving notifications (or if it stops altogether) for the same folders, if it's left running.

As soon as I start ChangeTest it's working, even in folders that are not monitored.
I also found that restarting Opus may help with changes made in Opus. It still doesn't refresh on changes made by external tools.
EDIT: But changes made before I started ChangeTest are not refreshing in Opus.

If change detection starts working in Opus after running a separate piece of software that uses the same API, then something is wrong outside of Opus. The problem must be in the components that implement/intercept that API (the OS itself, antivirus or filesystem/drivers).

Some part of the API is getting stuck, by the sound of it. Since it started happening recently and only to people on Windows 11, it may be a recently added bug in Windows 11, unfortunately.

It'd be interesting to keep ChangeTest running to see if it starts to see problems as well. I suspect it will, unless the API only goes wrong when a process requests monitoring of multiple folders, perhaps.

I have had the problem for years and it started with windows 10. I only find it annoying enough lately to dig deeper after I accidentally lost files Opus showed the wrong location for. The thread starter also has windows 10.
And if other software can see the changes while Opus can't how could a stuck API be the cause? This thing is extremely hard to troubleshoot because I don't know how to trigger the issue, I can only wait... I'll keep the ChangeTest running.

My mistake about Win11; I was getting confused with a different thread.

The Windows Desktop often misses changes as well (particularly if a sequence of changes are done to a single file, and more often when it's done via a command line program, for some reason; I often have to push F5 to get it to stop showing icons for files that no longer exist). Those bugs in the Desktop have been there for over 10 years with no sign of a fix.

Change notification in Windows is not always reliable, even in Microsoft's hands.

But what you're seeing isn't usual in Opus, either.

One thing which can be a factor is if there are so many events that the buffer for storing them overflows, at which point some or all may be dropped. Increasing Preferences / Miscellaneous / Advanced [Troubleshooting]: notify_max_time and notify_min_items could be worth a try, although that is a long shot.

Nothing that Opus does can really explain why things start working after you run another program (ChangeTest.exe) which also use the same API. That points to an issue outside of Opus, since Opus and the other program have no connection other than both using that API, and do not communicate with each other in any way. For the API to stop sending events until a second program asks points to a problem in the API itself. Unfortunately, we have no way of seeing inside Windows to understand what it's doing or how that could happen.

I also see this on the desktop an until now I thought this is the same issue but I just realized that I don't sync the desktop to Onedrive. To get to the bottom of this I'll test the settings you mentioned. I'll also check if the ChangeTest is indeed reliably fixing the issue or if this is a coincidence. I'm still not convinced that the problem lies outside of Opus if I let's say extract a folder with 7-zip and Windows Explorer sees the change but Opus doesn't. Also if ChangeTest pushes Opus to work why doesn't Explorer do the trick? I'll have to try everything that comes to mind...

Testing with Opus added to Defender's whitelists (there are two of them) is also worth a try:

I'll try whitelisting. It would be pretty disturbing though if ChangeTest would be able to override Defender, LOL
Thank you for your support btw! Much appreciated!

ChangeTest can't override Defender, but what Defender does is based on a lot of heuristics and can vary a lot between programs.

Today the issue re-appeared for the first time after I did the tests. I whitelisted dopus in defender and the problem was gone immediately. I don't know if this is really the solution because the problem was also solved by running the ChangeTest tool. Since I don't know what triggers the issue I can only wait a few weeks.
PS: removing the whitelisting doesn't reinstate the error, so...

I also have the problem with the updating issue in onedrive synced folders by using directory opus. Does it matter if I set other drive which is not the system drive? It is very annoying I have to refresh manually after copy/pasting, deleting and unziping. I am using win 11 and latest Opus.

It doesn't matter. I tried other volumes and other drives.

Whitelisting didn't help. The issue appears again after some time.


There's discussion of how to debug the issue above. We need those logs to see anything useful.