OneDrive Synced folders cannot detect content change

Hi i'm also now having the same issue where file changes aren't being seen in OneDrive in Dopus. I'm using Windows 11.

I'm running the change test tool and when I create a folder, rename etc in Dopus it does show up in the tool but not in Dopus until I manually refresh or go out and back into the folder.

Changes are being seen in File Explorer ok.

Is there a fix?

I am sorry to say no so far, they can not find out if the checking tool can not detect.

After my attempts, the only workaround for me is to leave a place for the folder tree as shown below and interestingly the refresh of the change will become automatic.

Does the change test tool pickup the folder changes for you as well Weeken or not?

So are you saying that if you have the folder tree open Dopus starts to pickup folder changes again? I don't use the folder tree normally since I just use the Dopus favourites system but if it fixes the issue until a more permanent fix can be put in place i'll try it out. I'll could put it in a very small window out the way

Is anyone able to assist with this please? I live out of OneDrive at work and not being able to see the changes is pretty annoying. Thanks

I just run the little change test program to work around this problem. I already experienced data loss because of this bug. Opus is showing files that actually are moved.

Btw, is anyone having this issue in a window other than detailed view with constant size calculation?

Might be worth trying the latest Opus 13 beta, as that has some changes to how the notification system works. (We may port those back to Opus 12, but it depends on feedback.)

While the work wasn't directly related to this issue, it's possible some of the changes we made recently (particularly to reduce the number of notification handles we keep open) may avoid whatever trigger is causing the OS to stop sending notifications (unless ChangeText.exe is also running). Of course, it's also possible it won't help, since the issue does still seem to be on the OS side (else running ChangeText.exe wouldn't make a difference to what Windows tells Opus is happening).

Could this be a problem specific to the OneDrive for Business Edition?

I run OneDrive Personal Edition on Win 11 and both Opus v12 and v13 detect changes immediately, even when executed on a second PC in my LAN.

My OneDrive is not mapped to a drive, it solely appears as Cloud Storage in Opus' Folder Tree.

Are you talking about the application here ?

I downloaded that for testing purposes and the updates do get reflected in that but not Dopus.

How does this app allow you to work around the problem?

I exclusively use detailed view with folder size calculations turned on.

Just to confirm are you talking about this setting being turned on? -->

Settings -> Folders -> Folder Behavior -> Calculate folder sizes automatically for fixed local disks only

I simply start the ChangeTest_64.exe without any parameters. It solves the issue for a few days.

My guess is that opus is flooding the api with requests until windows silently cuts it off. Thats why only a few people see this bug, because it's based on usage patterns. I never see the issue in folders with other view settings than detail view. This only happens in onedrive folders because windows handles onedrive differently. Onedrive is virtual, some or most of the files are not physically present on the harddrive (online only). Windows has to limit requests somehow to prevent serious lags.
On my system I can go for weeks without the issue re-appearing. It usually happens when I have lots of file operations to do. This makes it very hard to track and reproduce.

Has anyone with this issue tried Opus 13?

Yes, I also have this same issue with Opus 13. So I have to leave a place for the folder tree pane to make the refresh work even though I do not know why.

I'm going to try with Opus 13 today but sounds like Weeken's alraedy confirmed its still an issue.

I doubt there is anything we can do in that case. It appears to be an issue outside of Opus (else running ChangeTest.exe at the same time would not affect anything).

I suppose we could run something like ChangeTest.exe in the background automatically or something, but I'm not sure that is a real solution to whatever is going wrong inside the filesystem notification API (or Defender, possibly, since it's a folder containing documents and sometimes tools like that try to hide anything to do with them from other software).

So you still can not pick up the folder changes even if you keep the tree folder pane open?

For my case, maybe adding some codes similar to what the tree folder pane does in the background will help.

Considering the prevalence of OneDrive wouldn’t you want to make sure Directory Opus 13 works reliably with OneDrive though? If there’s nothing you can do work-around the issue does that mean DO13 will fully release with this issue and for some people using OneDrive in Directory Opus may mean not having their listers reflect the true state of the folder?

If a third-party utility such as ChangeTest is required to ensure this issue doesn’t happen, as s1de7 suggests, users could do that but it just seems there must be away to address this within Dopus itself without having to download other utilities to ensure the software works correctly, especially considering it affects such a prominent cloud service and the issue is quite serious when it hits.

I hope you can figure something out.

I've just downloaded DO13 so I need to do some testing on it so I don't know if this works or not yet.

However Dopus 13 has this really nice integrated tree within the lister itself so you can open multiple folders right within the lister itself without having to have the full directory tree window open. So for that reason I don't really want to have another pane open with the directory tree as it serves no fucntion to me and takes up space.

If something extra is required to ensure Dopus/OneDrive work well together I think i'll go with an external third-party app though.

Hi, Leo,
I come back to add some thought to this. (I'm the initiator of this thread and getting quite many replied lately).
For now I switched on the folder tree pane to somehow hack this, so temporarily it's working now.
However, shouldn't you still be able to do some fix on this? -- I mean I know you believe it shouldn't be wrong of DOpus itself, but seeing below facts:

  • in DOpus this issue exists with OneDrive, and it's annoying
  • If I get C:\ tab on, it's fixed
  • If I get folder tree pane on, it's also fixed
    From pure pragmatic point of view, aren't you be able to try a "OneDrive Issue fix" in the setting item, with which enabled, DOpus simply simulate the C:\ tab in one invisible pane, or the folder tree?
    We are not able to prove it's fault of DOpus but we are not planning to either, we just want DOpus back to be failure-free and frustration-free.

Do you think that's possible?