OneDrive Synced folders cannot detect content change

It doesn't matter. I tried other volumes and other drives.

Whitelisting didn't help. The issue appears again after some time.


There's discussion of how to debug the issue above. We need those logs to see anything useful.

@Leo Thanks for the feedback. Please help to check the enclosed debugview file, I repeat the steps as the above video does. (1.8 KB)

There's no change notification entries in the log (only ShellChange ones, which are secondary and not what matters here).

If notify_debug was on (not just shellchange_debug) then that indicates change notification is being blocked or broken by something on the system. Most likely antivirus.

Which antivirus are you using?

Have you tried the suggestions above to whitelist Opus to see if it makes a difference?

Running ChangeTest.exe may also be worth a try to see if your machine is also only sending change notifications when a second program also requests them. I don't know what the solution is to that (it's something going wrong in the OS or with low-level components like antivirus that can interfere with the OS) but it would mean you're seeing the same issue as the OP rather than something different.

I double-checked and found out what you described for the "change notification" stuff. I can see the "change notification" in other driver except the onedrive synced folder as below:

And I have tried to add to the whitelist as below, but I am not sure if what I set was correct/working.

I also tried the changetest, but seems not working except in the default location. Maybe I am not use it correctly :joy:

If ChangeTest.exe can't see any changes happening to the drive / folder, the Windows change notification system is broken on that drive/machine. I don't know how to fix that, sorry.

But it's really weird that can monitoer the change for the drive F which is not working in changetext.

And if I unlinked the onedrive and tried to test again, everything become normal that I can see the change appear in the debugview.exe and the folder can be refresh automatically. :sob:

After unlinking onedrive I also tested the changetest, it seemed still not working. Is it because my windows version is "win 11 pro workstation"?

ChangeTest.exe shouldn't be affected by Windows version.

Definitely something wrong with the OS, or something interfering with the OS (e.g. antivirus/anti-ransomware stuff, which often likes to be hyper and break things involving cloud storage and folders containing documents, while not informing you that it's breaking them).

@Leo I found it interesting that all will be ok and the files in the folder are getting updated timely if I open the folder tree viewer

Are there any workarround for this? Or an event script for updating the folder after any manipilation :sob:

Hi i'm also now having the same issue where file changes aren't being seen in OneDrive in Dopus. I'm using Windows 11.

I'm running the change test tool and when I create a folder, rename etc in Dopus it does show up in the tool but not in Dopus until I manually refresh or go out and back into the folder.

Changes are being seen in File Explorer ok.

Is there a fix?

I am sorry to say no so far, they can not find out if the checking tool can not detect.

After my attempts, the only workaround for me is to leave a place for the folder tree as shown below and interestingly the refresh of the change will become automatic.

Does the change test tool pickup the folder changes for you as well Weeken or not?

So are you saying that if you have the folder tree open Dopus starts to pickup folder changes again? I don't use the folder tree normally since I just use the Dopus favourites system but if it fixes the issue until a more permanent fix can be put in place i'll try it out. I'll could put it in a very small window out the way

Is anyone able to assist with this please? I live out of OneDrive at work and not being able to see the changes is pretty annoying. Thanks

I just run the little change test program to work around this problem. I already experienced data loss because of this bug. Opus is showing files that actually are moved.