"Open Command Window Here" creates New Folder instead?

Hello,
Just installed Opus 10. I've used the "command window here" context menu registry hack for years, and it worked with Opus just like with Explorer. I noticed Opus 10 now places an "Open Command Window Here" on the right-click context menu. It works just like the old reg hack, but there seems to be a problem. When I select this menu item for the root directory of a drive (C:, D:, whatever), instead of opening a command window, Opus creates a folder called "New Folder" instead! Is it just me? Works fine in every other case, but not in the root of a drive.

The "Open Command Window Here" item is part of Windows 7 rather than Opus. It should only appear if you hold shift while right-clicking a folder. (If it appears all the time, it might be modified or added by something else but using the same name.)

I'm not sure why it would create a directory when in the root of a drive. That doesn't happen for me. It could be a conflict between it and another context menu item or shell extension. Does the same happen in Explorer?

Opus has its own version, which is in the Tools menu by default in Opus 10:


It's also in the menu you get if you right-click the background of a folder:


I don't think it's in the menu for right-clicking a folder by default, but you could put it there if you want. (Seems to me you're more likely to want to open a prompt for the folder you're viewing than for a child folder, though.)

The Opus version should definitely work, so try that and see. But it'd also be interesting to work out why the Windows one is misbehaving for you, unless it also misbehaves within Explorer (in which case it's not related to Opus at all).

Hi Leo,
I'm sorry, I misstated the problem I was seeing. Would you care to take another crack at this? I see that the everything you stated above is working fine for me.

The problem is with the old "Command Prompt Here" reg hack that has been around for years (included below). This trick works MUCH better than the lame approach MS added in Windows 7. You can right-click any visible folder in a tree (or in the lister) and get a command window quickly and easily.

However, there is some weird interaction happening with Opus 10 now. If you use the reg hack, you will see that attempting to open a command window in the root of a drive inexplicably creates a new folder (named "New Folder") instead.

Here is the .reg file:
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\prompt]
@="Command Prompt Here"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\prompt\command]
@="cmd.exe /k pushd %L"

Even using that still doesn't create any folders for me, and I can't see how it ever would as it just runs a command prompt.