GP SoftwareTwitter
Opus FAQsManualCommandsObjects

"Open listers that were last open..." problem on v10


#1

Hi,

I am on Vista 32 and there is a problem with DOpus on either system startup, system login, or simply shutting down DOpus and restarting it.

What happens is that I at least get one default lister showing, in my system, a lister showing my root drives.

So, if I had no tabs, and do the close or re-login, the last folder is not remembered.

If I have 2 tabs showing, shut down, restart, then one tab is rememberd, but the 2nd tab is not remembered but back to the root folders.

If I do not shut down DOpus, everything is remembered OK.

This never happened on version 9. I did rebuild the shortcut through the options area.

So my guess is that the settings of the current listers are not getting saved correctly, or not being read correctly.

Thanks!

Steve


#2

What do you have set in Preferences / Launching Opus / Startup?


#3

Hi,

Here are the settings... There was no problem with version 9. Just after I upgraded to version 10. I do not use the Explorer replacement option.



#4

Thanks. That looks correct for what you're aiming for.

Note that exiting and launching Opus is no longer the same as what happens during boot. If you run dopus.exe on its own then it will always open a window. Fully exit Opus and then use the shortcut in Start Menu -> All Programs -> Startup to simulate what happens during boot. (That shortcut should have the 'NOAUTOLISTER' argument within it.)

If you want to see what Opus thinks it should be loading next time it starts (if set to Open the Listers that were open...), view /dopuslocaldata/State Data/openlisters.oll in a text editor. That might shed some light on what's happening (especially if it isn't actually being updated, for example).

(/dopuslocaldata is a folder alias. Just paste that path into Opus and it'll locate the right file.)


#5

Hi Leo,

All that is in that file is the following and it never changes. I even deleted it and a new one exactly the same was entered:

<?xml version="1.0" encoding="UTF-8"?>

<lister_layout flags="1" />

The lister data is getting remembered somewhere else. But I can say this. Upon restart, the lister that loses the last location data is the tab with the focus.

So, if I have 3 tabs, and the 3rd tab had the focus upon closing, when I restart, the first 2 tabs are correctly remembered, and the 3rd tab loses the location data shows the root drives with a fully collapsed folder tree. So in a non-tab situation with a single folder, that is lost on startup.

Thanks,

Steve


#6

Is the timestamp on openlisters.oll recent?

If not, something may be preventing Opus from updating the file.

If it is recent then I think there may be some misunderstanding about exiting Opus and what the "open the listers that were open when the program was last closed" option does. By default, simply closing all of open Opus windows will not cause Opus to exit; it will stay running in the background unless configured not to. It's only when it actually exits that the current window state is stored, and only after exit that the startup settings will have any effect. If you are closing all Opus windows and then exiting Opus (e.g. by rebooting the computer), then openlisters.oll will record that no windows were open when Opus was exited. See here for more info.


#7

Hi Leo,

That file is not where the lister layout is stored I think. It never updates, yet, some lister data is retained (for all but one of the tabs).

Is it somewhere in the registry?


#8

Nothing is stored in the registry.

Open two listers, then (with them both still open) use File -> Exit Directory Opus.

Does the file get updated then?