Opus 10 always opens a window when started

Both Opus and (and probably, but I don't know)
Windows 7 Home Premium 64-bit

Preferences are set as shown.

When Windows is started Opus starts in the background without opening any lister as expected. However if Opus is exited from the tray and then started via the Start Menu, the default lister immediately opens.

That is intentional.

You can add "NOAUTOLISTER" to the start menu shortcut if you don't want it to open a lister when you run it. (Look at the Start Menu -> Programs -> Startup shortcut and you'll see it has the argument.)

If you want Opus running in the background, presumably you want it running from startup. If you don't want Opus running in the background, presumably you want it to open a window when you do run it, instead of it apparently doing nothing the first time you run it and having to run it a second time for something to happen. This is also needed to make the Windows 7 taskbar always cause a window to open, whether or not the program is already running. The NOAUTOLISTER argument exists for situations where that logic doesn't apply.

I can't get this to work with Autohotkey. For example Run "E:\Program Files\GPSoftware\Directory Opus\dopus.exe" NOAUTOLISTER open my default lister. I've trying launching my shortcut with the NOAUTOLISTER parameter (which works outside of AHK) but the default lister still opens.

Is Opus already running when you run it via AHK?

If Opus is already running then running it again will always open a new window. (That's always been the case. There are ways around it if, e.g., you want a command you can run to ensure Opus is running when you're not sure it is yet.)

No it isn't. I even tried killing dopusrt. I've been running this for years, except for adding NOAUTOLISTER.

(It's only dopus.exe that matters here FWIW; dopusrt.exe running in the background won't affect what happens.)

Set Opus to run at startup and have a look at the shortcut created in your Start Menu -> All Programs -> Startup folder. If you exit Opus and then run that shortcut you should see that Opus runs in the background without opening any windows.

(This is assuming that Opus is configured not to open any windows at startup. If Opus is set to open windows at startup then it will always open them, whether or not NOAUTOLISTER is passed on the command line.)

(Also note that closing Opus's windows isn't enough to exit it. Use the Exit Directory Opus item on the Jump List, or File menu, or tray icon menu.)

The shortcut has no NOAUTOLISTER ("E:\Program Files\GPSoftware\Directory Opus\dopus.exe" NOAUTOLISTER) and works perfectly. It only AHK that has the issue when I'm programming the hotkey with the same command, or when setting the hotkey to the shortcut. I'm closing Opus by right-clicking the taskbar and choosing exit. Task manager does not show Opus running.

The 1st line should read "The shortcut has NOAUTOLISTER", not "The shortcut has no NOAUTOLISTER".

Ny guess is that you're not tellibg AHK to include the argument correctly. What does the command-line column in Task Manager show if dopus.exe was started by your AHK script?


The problem was with a script that edits the AHK script, compiles and then runs the script executable. The script wasn't getting compiled. The AUTOLISTER parameter works fine.

I'm sorry to waste your time.

This almost certainly has nothing to do with the topic here, but if anyone has start-up problems after upgrading to Opus 10, then it might be worth liking in the Windows startup directory.

After my upgrade, I found that Opus always launched a lister every time Windows started. That wasn't what I wanted, and differed form the behaviour in Opus 9.

I discovered that my startup folder contained two shortcuts, one of which launched a lister. I deleted that shortcut and got back to where I wanted to be.