Opus 11.18 x64 not responding after deleting directories

Every time I delete a folder, Directory Opus freezes with a "(Not Responding)" in the window title. The problem has started only recently on my computer.

Specifics are:

[ul][li]I am running Windows 10, 64 bit and Kaspersky Internet Security.[/li]
[li]Occurs when I right-click on a folder and choose the delete command or when I left-click on folder and press Delete key.[/li]
[li]Occurs when one or more than one folder is selected for deletion.[/li]
[li]Occurs only when the folder should be sent to the Recycle Bin. Does not occur when I shift-delete to permanently delete the folder.[/li]
[li]Occurs both when Kaspersky is running or when it is paused.[/li]
[li]The folder deletions (move to Recycle bin) do occur. [/li]
[li]However, there is always a lag of 5 and 7 seconds from the time I execute the delete command to when the "(Not Responding)" appears in the window title and Directory Opus is frozen/unresponsive.[/li]
[li]I have not had Directory Opus recover on its own. I have always had to end the task and restart it.[/li]
[li]Problem occurs on when deleting folders on different drives.[/li]
[li]Per task manager when Opus is not responding, CPU utilization of entire system is in normal range; for Directory Opus, it is 0% when the program is not responding.[/li][/ul]

The problem does not occur when I use File Explorer to delete files using either the right click & delete sequence or the delete key.

Any help or ideas you can give me to resolve this is appreciated.

"Problem occurs on when deleting folders on different drives." - Just to confirm, does that include the local C:\ drive?

One quick thing to test: Have Opus open in the background, then open Notepad.exe, and use Notepad's File > Open dialog to delete a folder. After waiting a few seconds, do either of Notepad or Opus become unresponsive?

If the problem only started recently, it might coincide with a software or Windows update, which could shine a light on the underlying cause. Windows has a Reliability control panel which can tell you what was updated and when over the last few days/weeks. (Control Panel\System and Security\Security and Maintenance\Reliability Monitor)

The steps to fix a corrupted recycle bin may also be worth a try. It's not guaranteed, but is something that's quick to perform and could solve things.

Failing all of the above, if you open Task Manager (right-click the empty part of the taskbar), then right-click dopus.exe on the Processes tab, you should find an option to create a dump file. Use that and it will tell you where it has placed the file. Zip it up and email it to leo@gpsoft.com.au and I'll see if it reveals which operation Opus is waiting on.

Problem occurred on all drives which have the Recycle Bin activated, including the c:\ drive.

With Opus open in the background, problem did occur if I deleted a directory with Notepad.exe.

I followed the steps to fix a corrupted recycle bin. It did not help.

Problem did not occur when I booted up in safe mode. However, it did occur when I selected msconfig \ general \ Startup Selection as Diagnostic startup.

I did create a dump file and can try to email it if you think it will help. Zip file is 80MB, which probably exceeds what my ISP will allow me to email.

Thank you.

GMail should allow that attachment size if your ISP doesn't.

If things work in Safe Mode then it's likely to be one of the 3rd party tools, shell extensions or antivirus causing the problem. Checking which were updated around when the problem started might narrow things down. With antivirus, sometimes disabling them is not enough (as their hooks remain in place, doing less but still potentially causing problems) and they need to be uninstalled for a proper test, but that may only be worth doing if something indicates the antivirus may be involved.

I have the same problem as Tom1976. All of Tom1976s specifics are the same in my case, with two exeptions:

  • the problem occurs in safe mode as well
  • i'm using Avira Antivirus

I tried even the same steps to solve the problem (de-install Aviera, repair recycle bin etc.)

Directory Opus Pro 11.19 Build 6005 x64
OS 10.0 (B:10586 P:2 T:1) SP 0.0

@Leo: I'll sent you a link to my dump file. I made it in safe mode after dopus has crashed

Hope to hear from you soon

I tried to resolve this problem by reverting to previous restore points and by going back to an earlier disk image, both of which evidently had the same problem and failed to work. I uninstalled many 3rd party programs and problem still persisted. I gave up on finding a repair path and rebuilt my system from scratch including a clean install of Windows 10. It was a lot of short term pain, but I have not had the problem recur.

Your freeze is caused by the File History shell extension which, despite being part of Windows 10, is written incorrectly.

More detail here.

It is reportedly fixed in the Windows 10 Anniversary Update. It doesn't look like your PC has been updated to that yet, so you may find the problem goes away once you have. If not, the thread I linked just above has a workaround.

The Windows update resolved the problem.

Thank you a lot for your quick support!