Opus (and Explorer) will not list *.xls & *.xlsx files

Opus (12.28) and File Explorer will not list files with the MS Excel extensions, .xls or .xlsx.

Files with .doc or ..docx or ppt or .pdf do list in both software

I have no idea what changed or if I changed a setting, accidentally. Can you provide advice?

I feel pretty stupid, I have been using Opus for years on several different Windows laptops. Current OS = Windows 11, with most updates and I have MS 365 subscription. Because this problem is occurring in both software, I don't think uninstalling Opus and re-installing will solve the problem.

If Opus is filtering out files, it should have a red hidden item count in the status bar, near the bottom-left of the window.

Clicking on that will temporarily turn off all filtering and reveal all files, which may then let you see them to work out why they are being hidden.

If File Explorer is also hiding them then they probably have the Hidden and/or System attributes set on them.

If they don't appear even then, then they either aren't in the location you think they are in, or something at a lower level is hiding them. (Antivirus or anti-ransomware software might hide documents from other software, for example, although they usually at least test them with File Explorer, so that seems less likely.)