Opus <-> Flickr problem

[quote="jon"]Sorry? I'm not quite sure where this confusion is coming from.

If you're using Opus 8, there is no Flickr support at all.

If you're using Opus 9, there is a section labelled "Photo Sharing" in Preferences, and a section in the Help file that describes how to use it.[/quote]

Ok once again to clarify:
I have upgraded fron Opus 8 to 9 - so 9.002 is the version I´m talking about.
First machine I did is my new 64 bit XP one. On this machine I have no explorer replacement - I have read the FAQ now and know, there are problems with it. BUT as well I don´t have the photo sharing option in Opus 9 preferences on this machine. Though there had been a flickr syncronisation during installation ... (wizard)

As I have my permanent licence today I tried to xcheck things on my laptop - it is 32 bit. There has been no wizard to sync with flickr, however I have the photo sharing option in preferences now on this laptop. And with this option I could sync with flickr - almost. My acount is found and acknowleged but when I wanted to download the pics from there, I get a message "temporary moved" and no pic has been downloaded. I´ll try to find out if I find something in the manual about it. I don´t dare to try an upload as I have to understand the structure in the new created folder first to get pics to the correct place as the only thing happend as I tried to sync was another new folder within my new created one ...

best regards

Fifth item down in your screenshot - "Foto-Sharing" :slight_smile:

you are quick ist spotting - saw it on the screenshot now (therefor removed the shot :smiley: ) but quite sure it hasn´t been there any longer during further research. I´ll check it immediately when I´m home again. Still having this 302 error temporary moved on pics I want to have downloaded. I have some of the pics here on the laptop, so the adding to the collection via identification works fine - however can´t download pics I have there on flickr but not on my laptop. any idea why ?

don´t get it - the one just causing the error is one of these I synced manually as it is here on my laptop. It is in the collection already. Don´t understans anything anymore :confused:

Ok, I see the problem. It seems like Flickr have changed their API slightly with regards to downloading the original version of an image.

We will try to have a fix out for this in a day or two.

[quote="jon"]Ok, I see the problem. It seems like Flickr have changed their API slightly with regards to downloading the original version of an image.

We will try to have a fix out for this in a day or two.[/quote]

Thanks a lot for your efforts - and you have been right, on my 64 bit system flickr can be accessed as well. Looked in the wrong place as to the wisard´s action I suppoed it to be somewhere in the menu. I reconnected to flickr again from the preferences and I´m as far as on my laptop now, waiting for a solution of yours. Wonder if this account remains available now. I have been an administrator every time when playing around with my new opus ...

best regards

This is fixed now in (at least until Flickr change their API again :slight_smile: )

sorry - it is not fixed for me. Any other actions to be done except installing 9.003 ?
There is a difference now: I have searched the first two pics by hand - and they are acceped now, but as I want to sync, I get the very same error window on the third picture and it is not downloaded....

Hmm I'm surprised - I just tested it again and it works fine for me. Can you describe exactly what you are seeing?

Same here...

Can you try removing your Flickr account from Opus and then re-adding it?

I just tested this here with a different account and it too worked fine.

I've just tried Flickr synchronisation for the first time, adding the account in DOpus, and I also receive the 302 error.

Would one of you be prepared to give me your account details so I can try to work out what's going on?

[quote="Flickr API"][ol][li]http://farm{farm-id}.static.flickr.com/{server-id}/{id}{secret}.jpg[/li]
It appears that you are using the third syntax (but not using the farm-id), and Flickr did not return an 'original secret' in its response to your request for a list of photos. I have verified that using the first syntax with the secret and farm-id returned to DOpus by Flickr works with my account. Perhaps this means that DOpus is assuming that the 'original' size is available, but that size is unavailable in my case? Maybe calling flickr.photos.getSizes to verify that the 'original' size is available and reverting to syntax 1 (above) if it is not would work? Disclaimer: I've never used the Flickr API and rarely use Flickr, so the above might be nonsense.

Incidentally, the synchronise attempt is abandoned after the first failed transaction. Would it be more appropriate to retry (perhaps once) and then proceed with the remaining items in the queue? In my case there were 35 photos to download and it only tried the first.

Hmm it's plausible, but I don't understand how the original size could not be available. This represents the actual image that you upload, and as far as I know there's no way to delete that and only keep the other "generated" sizes.

If you go to your flickr account and view one of these images, select the "all sizes" option, does it offer you an original size? If so, what's the URL of that image?

The size list contains square, thumbnail, small, medium and large, but the size named 'large' in this list appears actually to be the original (smaller than the default 'large' size), so you are quite right that it is available.

When using syntax 1 as described before, the image I obtained was the medium size. The link provided by Flickr for the large image is in syntax 3 and ends '_o.jpg', but the 'secret' it uses is the same as for the other image sizes. DOpus isn't substituting any value for {o-secret} when it constructs the corresponding URL: perhaps it needs to fall back on secret if originalsecret is not specified in the Flickr response? Does Flickr only treat access to the original image as privileged if it is larger than its default 'large' size?

Maybe it does, although there is nothing in the API docs about this that I can find. I'll post a message on the developer's list and ask.

The others in this thread having this problem - are your photos the same, in that the original size image you uploaded is actually smaller than the Flickr "large" size of 1024 on the largest size?

Are you able to try uploading a large (> 1024 pixels) image to Flickr and then see if you can download it through Opus successfully?

OK - problem solved (or rather diagnosed). Free Flickr accounts do not allow anyone access to the original size (if it is larger than 'large'), hence the absence of an originalsecret. See Flickr forum post and FAQ entry.

I've tried uploading a larger photo to a free account, and it seems that:
[ul][li]If the original is smaller than 'large', 'large' is unavailable but 'original' is available, using the same secret as any other size.[/li]
[li]If the original is larger than 'large', 'original' is unavailable but 'large' is available.[/li][/ul]It looks like it will be necessary to ask Flickr which sizes are available before downloading, and to use secret if originalsecret is not provided.

(You could also ask or determine if the account is a free one when it is added to DOpus. This is an inferior solution to the current problem, but it would also allow you to avoid initiating uploads exceeding Flickr's per-image limit for free accounts, unless there is a better way of doing this).

I've noticed one other small bug. In the DOpus preferences for a Flickr account, hovering over "User Name" and "Full Name" causes the current values to disappear. If you click to edit them they reappear, so it isn't a big deal, but it would be nice if they'd stay still!

I just wanted to mention that I´m on a free account only. However I only uploaded pictures with and below 800x600 so far - and that should be the maximum size for free accounts as far as I have understood. If you need any data, please tell me which and I´ll send them in a PM to you.

best regards

I just tried an upload - fortunately I had synced only two pictures by hand till now. The new one AND the two pics I had synced manually by the search button were successfully added to my flickr account. Upload works, however no sync by download ...

best regards