Opus in 2X RDP Android Session

Hi Leo,

I tried the steps you said and that didn't help. I opened the task manager to see if the program was running and there are two process - "dopus.exe" and "dopusrt.exe" It seems strange that this is the only program that won't run. I tried almost all the other programs installed on my computer and they run as expected. It must be a setting some where in Directory Opus that is wrong. If you want, I a can provide you the information to log on to my computer with your phone to see what is going on. I can right-click on the desktop while in a RDP session and I can open the Opus Preference screen. I am using Windows 7 Ultimate Edition 64 on a Dell Alienware laptop if that would help. I don't use layouts, I think I don't. I just set the Opus screen as I liked it and made it the default lister. There are so very many setting in Opus it is had for me to figure out what they all do, but I have it setup the exact way I like it to work and I would not want to change the way the setup works to accommodate an RDP session. If I have to, I can just use Windows Exploder in the RDP sessions. It is certainly not in the realm of the capabilities of Opus, but what do you do.

[quote="leo"]Hi Joe,

I installed the 2X RDP client on my Android phone, connecting to the RDP server built-into Windows 7 Professional x64, and I was able to launch Opus using it without any problems.
I tried using Opus, and launched it via the start menu, taskbar, tray icon and desktop double-click all without problems.
The only thing I can think of is that you have Opus configured to open its windows in an off-screen position (which might not be off-screen when using the computer directly, but is on the smaller tablet screen).
Try setting "Preferences / Launching Opus / Default Lister: Always over the mouse pointer", and make sure whichever method you are using to launch Opus is configured to open the Default Lister (not a Layout or anything else).
If you need further help or have any other questions about using Opus, please use our web forum for the fastest response and so that the answers we give can help other people facing the same issues:

All the best,

Hi Joe,

How are you launching Opus when you try? If right-clicking the desktop and choosing Opus Preferences works, what happens if you right-click the desktop and choose New Lister?

Does Opus appear on your taskbar? (Not the notification area or "system tray" next to the clock, but the main taskbar itself)

Sorry, I tried that, and no, the Lister will not open. Opus never appears in the Taskbar. If it showed in the Taskbar then I would know that it at least started and was somewhere else on the screen but this is not the case. Strange issue for sure. I have an Opus icon in the Quick Launch taskbar that I use to open Opus. I also have a Start Menu icon and the double-click on the desktop will start Opus too. I have tried everyone of these options with no success. I attached my exported Configuration file if that helps you. I don't know what is in this file but I think you can see all the setting I have, can't you?

[I removed the config after I downloaded it, in case it had anything sensitive in it. --Leo]

[I removed the config from your post after I downloaded it, in case it had anything sensitive in it.]

Try opening Windows Explorer, then pasting this into the location field:

%appdata%\GPSoftware\Directory Opus\Layouts\System

You should see three files, default.oll, dupefinder.oll and synchronize.oll. Rename the first one to _default.oll, then try starting Opus again. Does that make any difference?

If not, have you tried launching Opus when using Remote Desktop from a Windows PC, using the standard Remote Desktop client, rather than a phone/tablet?

(Also, I assume you're using the 2X RDP client on Android, but connecting to the standard RDP server that's built into Windows? That's what I tested myself, i.e. I was not using the 2X RDP server on the Windows side.)

Yes, I am using the built in RDP for Windows. I tried with a computer and Opus works there but it was different on the start up. When I log in on my computer Opus starts full screen, single tree, all the time. When I logged in from the other computer it started quarter screen, to the right and it was in Dual Tree View. It also did not start at my normal default directory, it started at "My Computer" which was interesting. I maximized the screen, selected single tree view and clicked on the Downloads directory, which is my default start directory. I then logged out and logged back in and Opus was now working as it does on my laptop. It seems Opus does something different in a RDP session than it does on the local laptop.

Forgot, I did what you asked concerning the file rename and that seems to make no difference, either remotely or at the local machine. What does that file do and do I need to put it back? Maybe it has something to do with Layouts which I don't think I use. Thanks for removing the configuration file. I don't know what is in the file but it might have my FTP access to my website. I kind of forgot I am posting to a public site.

Still no success on the tablet. I can open the Preference screen by right-clicking on the desktop but that is it. I tried to use compatibility settings, checked and unchecked all the settings for the shortcut, start as administrator, start with compatibility for every Windows version in the list, checked and unchecked all the settings in 2X RDP, tried to launch the program from Explorer using the exe file, tried to run the program using Run, checked the Windows event logs (nothing there), checked "Start Opus with computer and default Lister, no Lister" still no success. I am out of ideas, I tried everything I know how to do. If you come up with any other ideas let me know. Don't stress about it too much I can still use Explorer I just hate that program when you are very use to Opus.

On another note, when you use Explorer and click on a Library you have the choice to add a folder to the Library. How do you do that in Opus?

Are you sure you're logging in to the same Windows account when you do the "computer vs RDP" tests?

Yes, I only have one account on my computer to log in to. The interesting thing is all my other customizations are intact except the few I mentioned above. I can change the preferences in Opus and then RDP in with my other computer and the changes are still there. On the Tablet I can't get the program to start up, but I can right-click on the desktop and run the Preferences. These are also set exactly as they are with access from my laptop. Very strange and it seems it should have been a non-issue.

I imported your config and was able to start the program via RDP from the phone without problems:

(The folder tabs are all blank as I don't have the same folders.)

I noticed that Default Lister: Always over the mouse pointer was not set, so it's still worth trying that if you haven't already, although it should not normally make a difference in this case.

If you don't see any difference on your desktop after renaming default.oll then that is strange. Your config's default lister is maximized and has lots of tabs open for folders below the Documents library. Renaming default.oll and opening a new lister should reset things back to the "factory defaults" which would be a non-maximized window, showing C:\ on both sides.

If you type /dopusdata\Layouts\System into Opus when at your computer, does it take you to the same directory as %appdata%\GPSoftware\Directory Opus\Layouts\System ?

Hi Leo,

Yeah, I think I renamed the file and then log on with the other computer and that is why the configuration started different on that computer as in my last post. I did try all the settings concern the mouse over preference and none of them made any difference. May be when I get another Opus update it might fix itself. I hate to uninstall the program and then reinstall it because I have a hard time getting it back to the setup it is at right now which is perfect. It seems the configuration file doesn't contain all the settings, at least the last time I tried it it didn't.

Can you answer the question about the libraries I posted in the last message? "On another note, when you use Explorer and click on a Library you have the choice to add a folder to the Library. How do you do that in Opus?"

From the Libraries folder, right-click the library and choose Properties. You can add folders from there.

(Please ask separate questions in separate threads so they don't get missed while trying to solve the main issue.)