Opus Layout is blank on restart

Hello,

I recently updated to 11.18 from 11.17 and the Opus layout suddenly got blank - see attached


Deleting the Directory Opus folder from AppData\Roaming\GPSoftware and then running Opus again restores the default layout. However, the layout gets blank again once I restart my computer. I have also uninstalled and then reinstalled Opus but this didn't help either.

I'm running a fresh install of Windows 10 Pro 1511 x64 (did not upgrade from a previous Windows version) with all updates installed.

Thanks,
Fehmi

What is in AppData\Roaming\GPSoftware\Layouts ?

Are you able to create and then modify files below that folder, without a UAC prompt or anything like that?

What attributes are on the files which are there (if there are any)?

Attached is the directory listing and file attributes for the System folder which is the only folder under Layouts. I can create / modify any file under this folder.


I have noticed there are only 2 files in this folder when I delete the whole Opus settings folder and then let Opus create its settings. After that a 'default.oll' is created with the following contents -

<?xml version="1.0" encoding="UTF-8"?>
<lister_layout flags="1">
	<lister>
		<wp flags="2" rc="480,260,1920,1040" showcmd="3" />
		<layout flags="0x10b000009" view_mode="details,details" />
		<toolbars />
		<tree_expand>
			<tree1>
				<item id="{B52C30E0-7FF9-47CC-B112-A3D9374CD79E}" />
			</tree1>
		</tree_expand>
	</lister>
</lister_layout>

When the layout is blank after a restart, I can delete the default.oll file and all is well until the next restart. Then I have to delete it once again, and again :confused:

Are there any files in the Layouts folder itself, or is it empty apart from the System folder below it?

What is set under these pages?

  • Preferences / Launching Opus / Default Lister
  • Preferences / Launching Opus / Startup
  • (Also the 'From the Desktop' and 'From the Taskbar icon' pages, if you are launching Opus via either of those methods.)

There are no files or folders other than System folder under AppData\Roaming\GPSoftware\Directory Opus\Layouts. And the System folder has 3 files in it - default.oll, dupefinder.oll, and synchronize.oll

The details of the settings are below -

Preferences / Launching Opus / Default Lister:

  • Ignore folder format of Default Lister (checked)
  • Ignore toolbars of Default Lister (unchecked)
  • Update Default Lister automatically when closing a Lister (checked)
  • Default Lister positioning: In a fixed position relative to the monitor the mouse is on

Preferences / Launching Opus / Startup:

  • Launch Directory Opus automatically on system startup (checked)
  • Show introductory start window (unchecked)
  • Listers opened automatically when Directory Opus starts
  • Open the Listers that were open when the program was last closed
  • Include virtual folders (unchecked)

From the Desktop:

  • Open the Default Lister

From the Taskbar icon:

  • Open the Default Lister
  • If openlisters.oll exists, delete it from here:

    C:\Users\<username>\AppData\Local\GPSoftware\Directory Opus\State Data\openlisters.oll`
    
  • Then do the steps you mention above which let you open a normal-looking lister.

  • From that lister, use Settings > Set as Default Lister, which should force it to save over the default.oll file you've already been looking at.

Does default.oll have more information inside it after doing that?

If it does have more inside it now, see if restarting now works as expected.

I deleted the openlisters.oll and also the Layout folder under the Roaming folder. After opening Opus, the lister looked okay and I set it as default lister. The default.oll file had more information and I restarted the computer as instructed. Unfortunately, I was greeted with the blank layout on the restart.

Then I tried toggling off the startup items from the task manager. I turned everything off except 2 Opus entries - 'Directory Opus Helper Application' and 'Directory Opus'. I left the helped application enabled but disabled 'Directory Opus' from the start up. I deleted the default.oll once again and then restarted the computer. This time it worked - the layout is normal again.

After that, I toggled Directory Opus enabled once again from task manager and I was greeted with a blank layout on the next restart. I believe 'Directory Opus (Startup)' link under the 'Startup' folder is causing this trouble. I have been using Opus for years since v9 and I never had to disable it from the Startup folder before.

I guess I found out something weird - selecting 'Open the Listers that were open when the program was last closed' under 'Listers opened automatically when Directory Opus starts' in the Startup option is causing the trouble. When it is set like that, a blank Opus window (like the one in my original post) is automatically loaded on computer start (it doesn't matter if I had any open Opus windows at shutdown) and then makes this blank layout default unless I delete the default.oll or manually fix it.

Selecting 'Don't open any Listers' or 'Open the Default Lister' does not corrupt the default layout.

What does openlisters.oll look like when the problem occurs?

My bet is that the file is not being written properly during shutdown, which could indicate that something is killing Opus prematurely (Windows itself will do that if it takes too long, but it's not normal), or it's crashing during shutdown (can happen, particularly with buggy shell extensions that get into a state that explodes when they're unloaded), or the device the config file is being written to is not properly persisting all the writes made just before the shutdown/reboot.

Below is a copy of openlisters.oll in 'AppData\Local\GPSoftware\Directory Opus\State Data' folder when the problem occurs.

<?xml version="1.0" encoding="UTF-8"?>
<lister_layout flags="1">
	<lister>
		<wp rc="480,260,1920,1040" showcmd="1" />
		<layout flags="0x103000001" tree_size="356,0" view_mode="details,details" />
		<toolbars />
		<tree_expand>
			<tree1>
				<item id="{B52C30E0-7FF9-47CC-B112-A3D9374CD79E}" />
			</tree1>
		</tree_expand>
	</lister>
</lister_layout>

As you have suggested a buggy shell extension could be causing this, I disabled all explorer extensions other the ones published by GP Software using Sysinternal's Autoruns. I also disabled a bunch of extensions in the Everything tab of Autoruns (e.g. Dropbox, Skydrive, Listary, Nvidia extensions, and even Eset Nod32 extensions) but this didn't help either - the blank layout issue persists. I might have missed the actual culprit but I do not wish to render my system unable by disabling too many things.

I believe Autoruns has a feature to save the current data - would it help you to investigate the problem?

No need for the Autoruns data, after seeing the XML.

Do you have any script add-ins installed in Opus?

No, I don't have any add-ins in Opus. Actually I am quite novice when it comes to Opus - I just use the vanilla setup and I barely change anything in its default configuration :smiley:

I am guessing I have a software which interferes with Opus' and operation. For instance, I do have Listary installed for directory handling. I am also using DropBox, Microsoft OneDrive (which comes preinstalled with Windows 10). However, I disabled them all, plus bunch of security software like Nod32, Windows Firewall Control, and also Nvidia stuff using Autoruns. I might have missed the actual culprit but I am clueless now and I do not know how to proceed.

What happens if you have just one Opus window, with just one folder tab pointing to C:, then use File > Exit Directory Opus, and then re-launch it via the start menu?

Don't worry about disabling other programs for now. From what you've said in the last few posts, I don't think it will end up being due to them.

I first make sure Opus layout is loaded correctly by deleting both default.oll & openlisters.oll. Then I have just one folder tab pointing to C:\ by closing the second / dual tab and set this lister as default by doing 'Settings > Set as Default Lister'. After that I select 'Don't open any Listers' or 'Open the Default Lister' as the default layout and restart the computer. Below are 2 different scenarios.

Scenario 1: As long as I keep 'Don't open any Listers' or 'Open the Default Lister' selected as the default layout, I never have any problems. I can restart the computer, exit Opus from the notification area/system tray, or do a 'File > Exit Directory Opus' - Opus layout is always intact.

Scenario 2: After the first restart where Opus layout is correct, I select 'Open the Listers that were open when the program was last closed'. Then I have just one folder tab pointing to C:\ and restart the computer once again. This time I am greeted by the blank Opus window. However, double-clicking on the desktop gets me to a new Opus windows with proper layout. Then I close the blank Opus window, go to the proper Opus windows, set this lister as default by doing 'Settings > Set as Default Lister'. After doing this, Opus works fine again until the next restart. I have also tried doing a 'File > Exit Directory Opus' and the layout is still intact when I open Opus again. However, once I restart the computer, I get the blank Opus window :confused:

One other thing I'd like to mention - if I do not immediately open a new Opus window by double-clicking desktop and close the blank Opus window, I can no longer get a proper Opus layout again without first deleting default.oll.

Please try this test dopus.exe, replacing the one from Opus 11.18 64-bit (it won't work with any other version): leo.dopus.com/temp/dopus_11-18_64bit_test.zip

I first exit Opus, replaced the original dopus.exe with the new one you have provided, and then deleted GPSoftware folders from both Local and Roaming folders. Unfortunately, the blank Opus windows greeted me on the next restart : (

I have included the attributes of the new dopus.exe - could you please confirm that I am using the correct version?


I am just wondering if reverting back to a previous build could fix this problem. I believe it all started after the update to 11.18 but I cannot be certain unless I try 11.17 or 11.16 - maybe an update to another program is the culprit. I have checked your release blog but the links to previous builds actually download 11.18.

That looks like it was the right version. Sorry the fix didn't work.

Here's 11.17: leo.dopus.com/temp/DOpusInstall_11-17.exe