Output list of selected files as comma seperated?

Is there any way to output a list of selected files in a comma seperated format? When I use {Fs}, it sends them seperated by spaces. The external application I am sending them to expects them as comma seperated in it's parameter.

This question was asked back in 2009 by TriadX:
https://resource.dopus.com/t/output-list-of-selected-files-as-comma-seperated/8678

Was there ever a solution to this as I now have the same issue myself.

I want to pass multiple file or folder names to Powershell, which expects them to arrive comma separated.

The nearest I can get is to use "{allfile}" with the quotations and then manipulate the text in Powershell. Unfortunately this is no good if the selected files or folders have spaces in the name as there is no way to distinguish between a Dopus-passed space between two filenames and any spaces IN the filename.

This is the button code I'm using:

@runmode:hide
powershell -windowstyle normal -NoProfile -ExecutionPolicy Bypass -file C:\power\script1.ps1 -SOURCEPath {sourcepath} -SOURCEFolder "{allfile}" -DESTPath {destpath}

Lets you specify an alternative separator for codes that insert multiple filenames on the one line. For example, {allfilepath} normally inserts all selected filepaths separated by spaces. You could use {allfilepath|sep=,} to have the filepaths comma-separated instead.

https://www.gpsoft.com.au/help/opus12/index.html#!Documents/Codes_for_passing_filenames.htm

Thanks lxp.
I figured it must have been addressed in newer releases.

My organisation is still on Dopus 10.5.7 at the moment however and the sep= flag is not mentioned in the documentation, but it gives us more reasons to upgrade. I may have to use something like {allfilepath|filemq} for now and then read the file list into powershell. A long way around. Thanks for putting me on the right track though.

still on Dopus 10.5.7

Poor you! You are missing out on a lot of good stuff!