Pasting line-broken text when renaming files/folders

when renaming a pdf, I pasted the headline of the pdf, which was

Vergleichende Evaluierung der Sensitivität von SARSCoV-2 Antigenschnelltests

Between SARS and CoV, there is a symbol

but this was not visible when renaming.
There was a line break in the PDF.

I understand I should not paste line-broken stuff when renaming, but perhaps if possible it might be good if DOpus auto-removed that when pasting. (onedrive was complaining about that).

Which method of Rename do you mean?

All the ones I can think to try seem to remove line breaks already.

(FF FE looks more like a UTF-16 BOM than a line break.)

I have sent you a PM with a link to the file (it's not publicly available any more).
I copied the headline from the Viewer, clicked the file so its name becomes editable, then pasted the text.
When renaming, no problem is visible, but after renaming is complete, a square will appear (which I missed). It's not an issue for me, I just wanted to point you to some kind of line break characters that are perhaps used in pdfs that might end up in file names and might cause issues for some users. I am just going to pay attention now that I know the problem.

I can't see any issues there. There is a space at the end of the heading, which may be what's confusing OneDrive (but is perfectly valid in Windows, at least before a file extension). And maybe the square is because another character in the font isn't supported by the font you're using. But no carriage return is added to the filename.

Hello, there is a specif character, probably a line break character, between " SARS "and "CoV" in that headline. when I copy it to an ANSI text, it refuses to safe, I have to save it as UTF. So there is some character there. That character is not visible (but i think the cursor will "halt" there twice) when renaming, but is visible as a square afterwards. One drive does not seem to like that character. I am just mentioning that this character can make its way into filenames. It's not a big deal, but IF there is some "algorithm" that will automatically scrap certain characters when renaming (there IS some algorith that will create folders I think, when doing simple rename and using backslashes, I think I remember), then one could add that line break (or whatever) character to be substituted by a space, internally in Opus, on rename actions.
It has nothing to do with a simple space before an extension.

There may be a special character there but it isn’t a line break, or the heading would be split on to a separate line there in the PDF or when pasting it into a text editor.

Although when I checked using Chrome as the PDF viewer, and looking at the clipboard data in a hex viewer, it didn’t seem to put anything special there. Maybe it depends on the PDF viewer.

Whatever is there must be a valid filename character or the filesystem wouldn’t accept it. Why OneDrive has a problem with it, I don’t know. But even if there is a published list of characters OneDrive does or doesn’t accept, we couldn’t filter filenames to that as it’d mean no one could use those characters outside of OneDrive.

(Another possibility is the clipboard data containing half a Unicode surrogate pair or badly converted UTF-8 data, which would be a bug in the PDF viewer. That didn’t seem to happen with Chrome, at least the way I was selecting and copying the heading.)


I get this hex output:


I got this by cut-pasting from this viewer: PDF-ShellTools
on this document (same as i uploaded, just for other readers of the thread)

If you think it's the fault of the viewer, I will write there.

Like I said, not a big deal - I just wanted to mention this.

The curious thing is that this same character appeared in another uncompeletey unrelated PDF in the line break when cut-pasting too, so I was thinking it might be worth finding out what this is about.

Have you tried another PDF viewer? You can drop PDF files on most web browsers these days. That was what I tried with.

If one viewer's inserting strange characters into a title and others don't then it may be an issue with that viewer.