PDF Document Crashes Opus 10

I have a PDF file which always crashes Opus if I view a directory where it resides. You can find it attached in a ZIP file.
Static Disassembly of Obfuscated Binaries.zip (761 KB)

I should have attached a snapshot of the error.

No crash here so chances are one of the following:

  • It's already fixed in the version I'm using (which has a few changes in addition to the latest 10.0.0.4 beta).
  • It's only triggered if you have certain columns visible.
  • It's caused by a 3rd party PDF component. (You can use the SysInternals Process Explorer to find out which DLL the crash address is in. Make it show the list of DLLs for DOpus.exe, then trigger the crash then sort the DLL list by base address (add the column if not there already) and find the one with the highest base address that's still lower than the crash address.)

I am running Opus 10.0.0.0.4137.x64. You may find this snapshot a bit more useful.


Something else I noticed. When I start Opus in the process list I have, "dopus.exe" and "dopusrt.exe". After the crash when Opus restarts it only shows, "dopusrt.exe". Even though, "dopus.exe" is missing everything seems to be working, no hidden or terminated processes.

Dopusrt.exe just handles double-clicks on the desktop. If you can see an Opus window then dopus.exe must be running.

I am presuming that "dopus.exe" is the cause of the crash. I've tried getting a screenshot of the process DLL's after it crashes but it seems I'm too slow before it terminates completely. It seems to terminate straight after the crash now whilst before it would stay open for a while.

After it crashes I can double click and a lister window opens but there is no "dopus.exe" in the process list. Very odd.

Ignore what I said above. I found "opus.exe" seems to restart under the Task Schedule Engine "taskeng.exe" process?

I've tried with the release version of 10.0.0.4 and I still don't see any crash with (several copies of) that file in a directory.

I suspect some PDF-related software/shell-extension on your system is to blame, unless it's only triggered by having certain columns visible (you haven't said how your lister is configured so I can't try that).

What ever the problem was/is has been fixed in the 10.0.0.4 release. Just did an update and all is well.