Permissions issue? when launching DOS command from FAYT

I tried to execute the command ?copy C:\Windows\Minidump* (with and without asterisk). I also also tried:

  • to copy specific .dmp files
  • quoting the path for the folder and individual files (even though it has no spaces)
  • tried including the destination explicitly with {r} and {s!}
  • tried elevating the prompt

Regardless of what I try, I get an error indicating "an error occurred copying '<name of minimdump (which I did not explicitly provide, so dopus seems to be able to read the contents of the path just fine)>: the system cannot find the path specificed. (3)

Any idea what's going on? I'm guessing it is some kind of issue related to permissions UAC? I did try to ?dir C:\Windows\Minidump and that works just fine... so if anyone can shed any light on what might be going on, it would be much appreciated.

I realize I can copy files using dopus internal commands, but I'm more curious as to the behavior involved, so I can take it into account when trying to run DOS commands in the future.

Oh... and I guess while I'm here, I'll sneak in a feature request: Having the FAYT keep command history where appropriate (/, >, and ? commands). I keep finding myself wanting to hit up arrow and being disappointed when I realize oh wait... that doesn't do anything. The use case is when you're typing a command and you mistype something and the command errors out. Being able to hit up error, correct the type, and then rerun the command would be a much nicer workflow than having to retype the whole thing.

Thanks :slight_smile: