Photoshop can't save - DOpus is using files

Quiet often I can't photos with large filesizes (3+ GB) from PS because DOpus has it open or is using it in some way. Closing the lister I originally opened the photo from doesn't help. I have to close DOpus using Taskmanager before I can save.

Waiting for some minutes and then trying to save has so far not helped either. What is DOpus doing and is there a way I can get around this issue?

The photos typically gets opened from DOpus. I've set up a hotkey to launch PS with the selected photo(s) using: Photoshop.exe "%1"

We made some changes a few updates ago to help with this, so if you're not on the latest update try updating first.

The underlying problem is that Photoshop saves files by opening them, writing some data, closing them, then re-opening them, writing some more data, and so on. If it delays long enough before re-opening a file, Opus may have received notification of the file change and started reading the file to re-generate its thumbnail. Photoshop in turn isn't intelligent enough to re-try the subsequent file-opens and immediately fails the save if something was reading from the file at the time.

If you have Explorer set up to show thumbnails of PSD files, it could probably trigger the same problem. (But Explorer usually doesn't show PSD thumbs, while Opus has that built-in, so Adobe probably don't notice the problem with how they save files.)

Opus will normally only open the files if you are displaying thumbnails or have a column like Description, Width, Height, etc. open which requires opening files to get the extra data about them.

Thanks for your reply and the explanation, Leo. I'm on v12.7 and use TIFF.

I retried disabling any extra field and though it's too early to conclude with certainty, I'd say I had better luck with saving several large files this time. After a handful saves I ran into the issue again though. I also tried "using" Windows Explorer and didn't experience any issue. I was in thumbnail mode and also had the preview pane enabled.

I think the fix/workaround we added was for the way Photoshop saves .PSD files. Perhaps it does something different with TIFF files.

Is there a good way we can generate a similarly large TIFF file with the extra data that makes it more likely to happen, to test with? What kind of data is it that you're adding to the files? (We have the latest version of Photoshop CC.)

As for generating large TIFF files:

Open this in PS:
Convert the image to 16bit (image-mode-16bit/channel).
Add 20px Gaussian Blur and +50 saturation to force in extra data that will use more of 16bit.
Copy the layer 10 times.
Save as TIFF using LZW as image compression and RLE as layer compression.

These steps should get you close to 4GB, which is upper filesize limit for TIFF's.

I'm on latest Photoshop as well.

I had this feeling that pre v12 versions performed better (in other areas too), so after my previous post I downgraded to v11.19. I did tons of saves and only occasionally was not able to save - I kind of had hard time reproducing the issue even though I had image specific fields, was in thumb mode and had the viewer enabled. When it occurred, I never had to force close DOpus, but could either just close the lister or navigate away to parent folder, and could then save.

I then re-installed v12.7 and redid the same. Already on the very first attempt, I was not able to save and nothing worked until I force closed DOpus. I only had thumbs and no viewer or image specific fields.

I was hesitant in mentioning this before but after the more direct testing, I'm more confident in doing so: v12 crashes way more than previous versions. On previous versions a crash would be rare while V12 can crash several times a week. I suspect it might have to do with photo RAW files (DNG format from Pentax cameras) or images/video in general.

V12 can at times be very sluggish. It's hard to put my finger on what and I'll try to pay more attention to it the next time it happens.

Intrigued by what Zafar_Iqbal is saying, I took his picture and did what he said to create a 2.44 gigabyte tiff. The first time I saved the file the saving operation was very fast up to 92 percent and slow - really slow - after that, but the file did save,

However, when I edited the file - I deleted some layers to make it smaller - I ran into his problem after about 94 per cent saved I got the message he gets.

I know it is a bit academic as who needs 2.5 gigabyte tiff files cluttering their disks, but the "problem" does appear to exist. But one would imagine that for 99 per cent of Photoshop users it is largely academic.

I was perhaps a little previous in my last post. The real problems started when I tried to delete the large Tiff. Like Zafar I got the message that the file was in use by Opus, and that persisted after I killed Opus in the Task Manger.

So I rebooted the PC and tried to delete through Opus again. To my surprise, I still got the message that the file was in use in Opus.

I killed Opus again and then had to use Explorer to delete the file.

Could there be something a bit deeper here?

So far, I haven't tried deleting such large TIFF files until now, when I went through the steps to see what kind of filesizes I was reaching. I couldn't delete the file as well until I used Explorer.

That isn't normal. It could be a bug in the Raw plugin, or it could also be a third party shell extension that's crashing. Please send us any crash dumps and we may be able to use them to pinpoint the cause.

But let's also keep this thread to the topic it's about, please (Photoshop TIFF saving).