GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Play command prevents further execution

It seems that having the Play command (in the Standard Function script) stops any further execution.
So if you have something like this:

Play "bell1.wav" QUIET
Play "bell1.wav"
@confirm:Hello!

The sound will play only once and nothing else will happen after it.

Looks more as if the player will ignore further Play commands when it's busy. If you put the @confirm line between the two Play lines you'll hear the sound, see the dialog, and hear the second sound after pressing OK.

Just tried this:

Play "bell1.wav"
@confirm:Hello!

and the sound plays, Play window closes, but no messagebox pops up.

That's odd. I am getting the dialog while the sound is still playing. Only difference I can spot is that I included the path to the .wav.

Maybe different systems? Here's mine:

Directory Opus Pro 12.14.2 (Beta) Build 7087 x64
OS 6.1 (B:7601 P:2 T:1) SP 1.0 "Service Pack 1"

Could be, here's mine:

Directory Opus Pro 12.14 Build 7076 x64
OS 10.0 (B:17763 P:2 T:1) SP 0.0

(I've also included the full path to .wav, removed it for forum example of course)

12.14.1 has some changes around the Play command, which might explain the differences on your two setups.

Yes, I tried this on 12.14 and could reproduce the initial problem. So, something to look forward to in 12.15 :slight_smile:

Or be brave and try the beta :wink: