Power mode keeps activating (apparently) by itself

Hello!
I have all my folders in "Detail" mode but, from time to time (and it seems increasingly more often), while I am in a folder doing something (ie: deleting or renaming files) it changes to Power mode without me doing anything. Is there maybe a combination of keys that activates it without having to do that in the toolbar? If there is, I could not find it.
This is quite annoying, because everytine I have to deactivate it from the toolbar.
Thank you and have a great day.

There's no default hotkey to switch into Power mode, but you might have added one. Check via Settings > Customize > Keys.

It's also possible folder formats have been configured so that some folders switch to Power mode when you enter them. Hovering over the format lock (or info icon) on the status bar will tell you where the current format comes from. (Hover only; don't click it.)

Hello Leo and first of all thank you for your help.
There is no hotkey for Power Mode in my settings:
image

This is what appears hovering on the lock for the last folder that gave me the issue:
image

And the folder is now on Detail mode (I put it back that way)
image

Thanks again!

If it can help, it usually switches to Power mode when I rename flac files in a folder.

That's definitely not normal. Have a look at the Rename button you're using, or anything else you click while doing those renames, to see if it includes commands to switch modes.

The folder format lock is also on, which means any changes you make to how the current folder is displayed will stay that way for all folders in the current window. (And subsequent windows if you have Opus configured to automatically update the default lister when the window is closed.)

I press F2 to rename files. Then I enter the new name and the issue usually appears after I confirm the change with Enter.
This is what is associated to F2 key:
image

Also, this is the only setting that has something to do with Power mode:
image

But of course I never press CTRL+NumPad while renaming files. Anyway, I have tried disabling it.

I don't really understand why it does this.

Thank you!

Please double-click the first F2 entry (the one with Name = "Inline Rename").

What's the command it runs?

image

Also please note that it seems to happen randomly (of course it is not, it is just that I could not determine what activates it), so it cannot be something associated with F2, which I use a lot without any problem.

That F2 key/command looks fine, at least.

In a stock config, the only thing that would turn on Power mode is the toolbar/menu items for it.

Something must trigger the change. Maybe opening a new window or layout or applying a lister style. If those were saved with Power mode on, they'll turn Power mode on when they are loaded. (But none of them have Power mode on by default. It's basically not used in the default config.)

Leo, would running an automated search for files containing "view=power" in all the DO configuration folders help to clarify the issue? The results might help to determine if the user have configured the command in a script, hotkey, folder format, etc.

Find * CONTAINING "view=power" CONTANYWORD CONTUTF8 IN /dopusdata /dopuslocaldata /dopusglobaldata

As a button:
FIND test.dcf (343 Bytes)

Hello errante and thank you!

I did run your search and it gave some results. Unfortunately, it looks like it found just a few files and they do not seem to trigger the Power mode.

Also, please note that this usually happens with folders that I touch for the first time to rename the flac files I have just extracted/downloaded.

Thanks again!

It keeps happening and I can't figure out why.
It seems to be always with new folders containing music files with "Music" view. After I rename some of them (or sometimes after I delete some non-music files - like .txt - from those directories), sometimes the view switches to Power mode by itself and sometimes it doesn't.
This is quite annoying, and I do not know how to fix it.
Thanks for all your support!

Maybe you've set the Music content type format to use Power Mode?

I would go through all the formats under Preferences / Folder Formats and make sure none specify power mode.

I would also clear the automatically remembered formats.

Hello Leo.

I have checked and it was set on "Power Mode". The point is that I am sure that it is the first time that I have entered "Folder Formats-> View" so I don't know how it was set that way.
Also, it doesn't explain why it happened just some times and not always.
Anyway, hopefully now it is fixed. I will let you know if it happens again.
Thank you and have a greart day!

Content type formats depend on what’s in the folder.

None of them are set to Power mode by default.

I understood this.
The point is that something must activate it without me doing anything and the prove is that it just happens sometimes and not always.
Anyway, let's just hope that what I did fixed it once and for all.
Thank you!

Going into a folder with enough files of the specified type could activate the content type formats. (But nothing would have set them to use Power mode by itself.)