GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Preview freezes DO

Seems that certain files freeze my DO if I have the preview pane opened and try to righclick on them (for example, get a few of Russel Brown's tutorials: the one under CS3 Extended: Painting and Cloning on Video / Posted 3/27/2007 seems to be problematic).

Is there a way to prevent crashing? The only workaround I found so far is to turn off the preview pane or maybe disable the plugin that handles .mov files but performing this every time before I go to certain directories is a bit impractical. I guess there must be a better solution?

Did you check through Leo´s FAQ on this topic?

[Crash, exit or high CPU when right-clicking certain files)

If MOV files are unstable my bet is they're being shown using QuickTime, though Opus's ActiveX plugin. (To confirm that, does it look like Apple's QuickTime's thin, dark grey seek-bar below the video? Or does it look like the toolbar/seek-bar you get when you play an AVI or WMV file?)

It seems to vary with different versions but QuickTime doesn't always work brilliantly and you should find things are better if you install the splitters/codecs required to play .MOV files via DirectShow (which is what Opus, Windows Media Player and most other things use).

If you do that then Opus's Movie plugin will be able to play the .MOV files and they won't drop through to the ActiveX plugin or QuickTime.

(You can also remove .MOV from the ActiveX plugin to prevent it ever handling them. To do that via Preferences -> Plugins -> Viewers, select the ActiveX plugin, click configure, then select Generic ActiveX at the bottom and remove the .mov extension.)

There's a guide to getting (most) .MOV files to play via the movie plugin here:

[HOW TO: Enable/fix playback of various media formats in Opus)

abr: yes of course - when I bought DOpus... and by now forgot everyhting of course so thanks for reminding me!

leo: After it froze, the seek bar was not looking like the Quick Time seek bar but like the one the one that appears while previewing AVI files (WMP style).

Just went through the FAQ and disabled the Movie plugin and now the preview pane doesn't freeze and I can preview the movie (the seek bar looks like QT).

I'll follow through and completely disable the preview of .movs, they were nothing but trouble for me ever since my comp crashed during an installation and all my attempts to reinstall / fix them were in vain.

Thanks for the help guys!