Preview of media files – always at maximum volume?

As a quick check of recently bought mp3 files, I like to preview them in Opus.

As I negotiate from one file to the next, it always sets the volume to maximum. Not great for the ears when you want to preview a dozen files in a session.

Is this just me? Am I missing something that lets me set the volume?

In the viewer pane, or do you mean Opus's play command?

(Why not change the system or speaker volume, if it's too loud for general audio files?)

Viewer pane.

Is that a serious suggestion? Why should I reset all of my levels just because one piece of software is incapable of controlling its own output?

It isn't "too loud for general audio files". Everything else plays at a sane level.

It's not actually Opus doing the playback - it's just a host for whatever viewer (probably Windows Media Player) is actually playing the sound. If that doesn't provide a volume control or remember its level from file to file there's not really anything Opus can do about it.

It's not like adjusting the overall system volume is that difficult, is it?

That makes it easier to understand. I will investigate.

But I switched to Opus from Media player That played at a sane volume. Setting Media player at an acceptable level has no effect on the playback volume in Opus.

I have just discovered another failing. I can set the playback volume of Opus using the Volume Mixer. (Directory Opus ActiveX Proxy.) But even that does not stick between files.

Please stop repeating this silly red herring. It is no more than an attempt to duck the issue.

Of course it is "that difficult".

Every other piece of media software is set at an acceptable level. I have a load of different sound sources and playback software? Why should I have to adjust them all to deal with one seemingly straightforward task that appears to be beyond the capabilities of Opus?

My solution at the moment is to abandon Opus ro preview mp3 files.

Opus isn't "media software".

Who said it was?

Are the MP3s you're playing exceptionally loud, or have you got your system-wide volume set really loud and compensated by turning down the volume of every application which plays music?

We're not suggesting the system volume be adjusted as a cop-out, we're suggesting it because it's the normal thing to do, and what we've done ourselves, and should solve the problem unless something unusual is going on (like the MP3s being previewed are much louder than other typical sound files you might play in other applications).

You could have fooled me.

No. They play fine in everything else. These are commercial (eMusic) files that aren't likely to have wonky sound balance.

Here's a screen grab of one set of levels. (It misses out on many other inactive sound channels on my system.) I hardly think that the sound level is "exceptionally loud". In any case, does that matter when everything else, including Opus (see below), lives with that level just fine?

As you can see, Opus always sets itself to the speaker level. Everything else works fine with a reduced setting.

Please don't tell me that I have to drop the speaker level simply to fit in with the quirks of Opus. Note that one input is deliberately set at the Speaker level.

I have just conducted yet another experiment. This shows that an mp4 file previews in Opus perfectly, similarly mpeg. The volume slider is at a reasonable level. Here is what that looks like:

If the mp4 level happily sits below maximum, why not mp3?

I can adjust the mp3 levels file by file, bit it does not stick.

On the other hand, the Opus previewer does remember zoom settings for PDF files.

Does anyone else see this bonkers behaviour for mp3 files? Or is it just me. Have I got something set up all wrong?

Like I said, Opus isn't the one playing the mp3 files, so there's nothing we can do about it.