Print Export Folder Listing Error (Win 11)

I am running Dopus on both Win 10 and Win 11 machines. No Dopus problems on the Win 10 machines. The new desktop came pre-installed with Win 11, the laptop was an upgrade to Win 11.

On both the Win 11 machines the Print Export Folder Listing produces this error message. This one is from the desktop but I receive a similar message on the laptop but do not have access to it at the moment to grab a screenshot of its specific message.

I did follow the suggested action on both machines, and it does successfully terminate the thread but it after restarting Dopus the same error message appears for this function.

I hope there is a fix for this feature :slight_smile:

Please send us the crash logs and we'll take a look:

It's more likely to be due to the file types and columns involved than the OS version, although both are possible.

Thanks Leo. Sent them over.

Many thanks!

It seems to be crashing inside the Windows print spooler, but I had a look at how we are calling it and found something that could be the cause. It's strange if it hasn't affected any other setups until now, but maybe some print drivers make the API more sensitive than others.

Please give this dopus.exe a try over the top of a 12.29 install:

  • Extract (12.8 MB)
  • Open C:\Program Files\GPSoftware\Directory Opus in File Explorer.
  • Make sure Opus isn't running (File > Exit Directory Opus)
  • Copy the new dopus.exe over and restart Opus.

(If you need to go back to vanilla 12.29, just re-run the installer over the top of the existing install.)

If that still doesn't work, are you able to print things, as well as show the printer setup window, from other programs?

1 Like

There are also recent reports of printer-driver problems with Windows 11, which could explain what you're seeing:

Thanks for the heads up and article link. I'll have a look.

Updating my results for the forum. The updated exe file worked for both the desktop and laptop machines running Win 11. In my case, Dopus crashed even before getting to choose a printer and after replacing the exe file it works beautifully again.

1 Like

That's great to know. We'll include that change in the next update. Thanks for testing it!

Just adding that I experienced an identical situation on a Windows 10 laptop. I found this thread, and the updated EXE also resolved the crashes for me.

1 Like