Problem associating .wmv files

I am using Dopus 10 on Windows 7 64-bit, and have experienced problems with Windows Media Player 12, which sometimes stops working when playing a .wmv video and the wmplayer.exe cannot be killed, so I need to reboot to restore order. Trying to kill the process from the Task Manager just makes the window disappear, but the process lingers on, and prevents any new Media Player window to appear.

It seems that both the 32-bit and the 64-bit wmplayer is preinstalled with my Windows Ultimate system. I notice that when I double-click on a .wmv file in a Dopus window, the 32-bit player will start. So I want to associate .wmv-files in Dopus with the 64-bit version instead, to see if that would make the playback problems go away. However, when I choose Change in Dopus file type window and browse to the 64-bit version of wmplayer.exe and select it, I just get the answer "wmplayer.exe is already in the list". And so the .wmv extension is still associated with the 32-bit version of wmplayer.exe.

Does anybody know how I can reassociate .wmv to the 64-bit version of wmplayer? ... 50798d5113 has a few methods.

The difference is likely to be different codecs installed for each version, rather than anything inherent to 32 or 64 bit, so fixing the codecs is another option. We have a guide in the FAQs with suggestions but it can be quite a pain, as video codecs are a mess in general, so if 64 bit wmp works then that'll be easier, I guess.