Problem opening files through context menu

So I'm trying to find an acceptable text editor for everyday use and I've tried a handful but I'm having some problems. I'm wondering if some of them have something to do with DOpus. I'm not very computer-savvy and feel generally overwhelmed/intimidated/frustrated by DOpus despite having read the manual, spent countless hours trying to learn basic usage through forum/manual/help reading, and actually finding it useful and promising enough to actually overpay for recently, so all advice is appreciated!

With some programs (e.g. recently TextPad and Wavelab for .txt and sound files respectively), I select a file in DOpus and then select "open with" in the context menu. What's supposed to happen is that the program I select shows up in the list of programs in the dialogue box and then gets launched to open in the file. Instead, what happens is that the program doesn't show up and the default program is used to the open the file. Where is the problem--with DOpus? with TextPad? Is there a solution?

Here's another problem I've had with the interaction between DOpus and a text editor, specifically NoteTab, which I really like otherwise. I'll open a txt file to view and then close it. If I try to rename the parent folder in DOpus, it won't let me because of "file in use by another program". I have to actually exit out of NoteTab entirely to free up the file for DOpus manipulations. This is a huge inconvenience because I like to keep many tabs of text files open at all times. I don't have the same problem with other text editors. For example, I recently tested Crimson Editor and it opens files from DOpus without any problem and even while the file is open DOpus allows me to change file names, even of the file itself.

So these are really basic file manipulations I'm having these serious problems with. Any ideas? I really like NoteTab and TextPad in general, but as it is they are not usable with DOpus for me.

I even tried totally reinstalling Wavelab, which I've used for years with no such problem, but I still can't open files through DOpus.


Easy way to check whether Opus is part of problems like this is to shut down Opus and see if the same things happen in Explorer.

The Open-With menu could be an Opus-related problems as then Open-With system is a bit weird and sometimes people discover things that Explorer does which Opus isn't emulating yet. (All the known ones have been fixed though, AFAIK. If you find a difference let us know which program is causing it.)

The directory-in-use issue isn't caused by Opus and will almost certainly also happen in Explorer (unless Explorer is launching the editor with a different "current directory", in which case let us know and I'll explain hwo to make Opus do that as well). It is probably caused by the editor setting its current directory to the folder with the last file it opened.

Assuming the problem also happens if you launch the editor from Explorer, have a look at the editor's preferences and see if there are any options about the "current directory" or "working directory." For example, in TextPad there's an option called "Working folder follows active document" and if that's on you won't be able to delete the folder which TextPad last loaded something from without either opening a different file in TextPad or exiting TextPad.

(BTW, If you're trying TextPad for the first time and finding it buggy, give it another try in a while. Until version 5.0 just game out it was a really stable program. 5.0 is fully of problems and didn't seem to be tested very well before release. :frowning: Despire the lack of Unicode support, ugly icons, etc., TextPad is still my favourite editor.)

That's impeccable logic and I thought to do the same thing, but I'm embarassed to admit I have no idea how to run Explorer! I have DOpus set as an Explorer replacement, so everything I do opens DOpus instead. There must be an easy way to do this, but I can't figure it out.


Start -> Run -> Explorer.exe :slight_smile:

If you find you can't double-click folders in Explorer without them opening in Opus, either use the Tree to navigate or right-click the folders and select Explore.

Okay, after testing in Explorer, I can say the "open with" problems are due to the other programs, not DOpus.

Many thanks for the tip on file-in-issue issues. It appears NoteTab doesn't have an option to fix that, so it's scratched off the list of editor candidates.

I just tried EditPad and it appears to be the winner. Everything works perfectly with DOpus ("open with" works fine and no file-in-use problem) and it's a great program. Actually, I used to use this program for a very long time and was very happy with it, but then they came out with a new version I didn't like as much, so I started trying other programs. I can't even remember why I didn't like the new version, but it was probably a trivial matter. Testing it now, I like it MUCH more than any of the others I've tried. Home sweet home!

Thanks for the great help and sorry to have done such poor troubleshooting on my own before posting! Someday I'll be a wiz and help others.


p.s. The "explorer.exe" thing is pretty funny! Classic newbieism!

FWIW I've been using NoteTab Pro and Opus simultaneously (especially using Opus to open files in NoteTab) for years and I can't say I've experienced the problem you've described. Just now I tried to duplicate the problem intentionally and it doesn't happen for me. I wonder which version of NoteTab you were trying? (I use the Current Pro version 5.1)

Interesting and good to know. I was using the free light version so perhaps the pro version has an extra option to avoid that.


There's no option to set that I know of, all I can say is I don't have that problem with Opus and the Pro version of NoteTab.

To me NoteTab Pro is the Directory Opus of text editors, but I admit I'm a bit biased. :wink: