Problem opening JPEG, PNG etc

I have Directory Opus installed on two PCs and on one of them I have been experiencing an issue for a few weeks where I am unable to open (at least) JPEG and PNG files directly from a lister.

When I double-click on eg. a JPEG file I get to consecutive error messages. First "The specified procedure could not be found", and then "The file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings page.".

I have made sure that the correct app has been set as default in Windows Settings (Microsoft Photos), and that the 'File Types' settings in Directory Opus seem correct. In both cases they are identical between the PC where it works and one where it does not. On the PC with the issue I have also installed Microsoft's 'Photos Legacy' and tried changing the default to this, as well as back to 'Photos', but the issue persists.

When right-clicking and selecting 'Open with' I get the same error messages for 'Photos' and 'Photos Legacy', but it works eg. with Microsoft Paint. Also, the built-in preview in Directory Opus works fine (eg. thumbnail view in the lister).

I should also note that I've done a reset from Windows Settings to default for all app associations. No change...

Any ideas?

Which versions of Opus and Windows are you seeing the problem on?

Windows version 11 Pro 22H2.

Directory Opus version 12.31 x64.

Couple of things to try:

  • Make sure no Compatibility Settings are turned on for dopus.exe. (If it thinks it's running on an older OS, it might not work properly with Microsoft Store apps like the Win11 Photos app.)

    See Windows Compatibility Settings / Wrong DPI / Installer misdetects OS for details on how to check that.

  • Assuming that's OK, comparing the file type settings between the two machines may reveal the difference.

    • Settings > File Types
    • File > Diagnostic (at the top left of the File Types dialog)
    • Enter JPEG or PNG as the extension.

    That will save a zip file to your desktop. If you do it on the machine with the problem and send it to us, we can take a look. (The same from the working machine might also be worth doing, if it's easy, but we can compare with our own Win11 machine as well, so that's less important.)

Sorry for the late response. I mistakenly replied to the 'noreply' email instead of posting here.

I’ve checked the compatibility settings, and they are not turned on.

Attached is the diagnostic file for PNG from the PC where this is not working.

Thanks for your help! (54.0 KB)

On the two machines, if you go to Microsoft Store > Library (bottom left), then select Microsoft Photos and scroll down, do both machines have the same version installed?

Your diagnostic file shows version 2023.11030.27009.0 is installed on Windows 10, while my Windows 10 PC only has 2023.10030.27002.0 and doesn't find a newer version.

That version difference could be why it's not working on one of the machines, especially if it's a beta ("Insider") release of the photos viewer.

Edit: Looks like you're using Windows 11 (or rather 10.0 build 22624, thanks to Microsoft's brilliant version numbering!) which may explain that difference. I'm checking on a Win11 machine.

The only other thing I noticed was this entry:

64 HKCU\Software\Classes\.png\shellex\{E357FCCD-A995-4576-B01F-234630154E96}:
  "" is REG_SZ: "{8AD5CECD-DF0D-41C3-BA21-1E22114CC73C}"

That {8AD5CECD-DF0D-41C3-BA21-1E22114CC73C} appears to be something Google Drive FileStream (GDFS) installs and there are threads about it breaking things in strange ways, although usually icons/thumbnails and not double-clicking. (GDFS has caused other strange issues in the past, though.)

I checked on a Win11 machine and that has 2023.11030.27009.0 the same as yours, so the version of the Photos app can be ruled out as a possible cause. Launching it from Opus is also working OK for me on Win 11.

Other than the GDFS possibility, I can't see anything obviously wrong on the registry side of things.

Something to check:

  • Select a .PNG file

  • Type > into the file display. A command field should open at the bottom.

  • Paste FileType ACTION=shellex SHELLCLASS=AppX43hnxtbyyps62jhe9sqpdzxn1790zetc into it and push return.

    (The AppX43hnx... code is Microsoft's internal name for their Photos app.)


Does that trigger the same error, or does the Photos app open and show the file?

This also seems to be a more general error that some people see with the Photos app on Windows 11, without Opus being involved. Possible solutions are here:

Hi and thanks for your help!

I've now tried the following:

  • Checked the Photos version, and as you predicted, they were the same.
  • Tried the Dopus shell command. Same result
  • Tried both repairing and resetting the Photos app as described in the article you linked to, including the PowerShell approach.

In the end I went through the registry searching for 'Photos' and deleted every single key that referred to Microsoft Photos (not MS Legacy Photos). This actually seems to have resolved the issue. Dopus can now open files both in Photos and Legacy Photos!

Thanks for the help - I was sure this was a Dopus issue and would never have been able to fix it without your pointers!

I'm also facing the same problem. A script would be a lifesaver, anyone willing to share?