GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Problem opening RAR files within Opus


#1

Hello everyone!

I'm having a problem figuring out how to configure Opus to open RAR files and I'm hoping someone can help me sort things out. I've read through many forum posts - including the FAQ article titled "HOW TO: Make RAR files open in Opus on double-click" - but I still can't seem to get it to work.

As instructed by the FAQ article, I did a search of my entire "C" drive to locate any additional unrar.dll files that may be creating a conflict. I found around 5 or 6 of them in total - one in the System32 folder, one in the Opus VFSPlugins directory and a few others in folders related to other programs. I renamed them one-by-one to see if they were creating a conflict with Opus. Lastly, I renamed all of them at the same time to see if they might be creating the problem collectively. I tried opening a RAR file within Opus after renaming each individual file.

In the end, I had no luck as Opus kept giving me an error (something about a problem with the archive). I tried many different RAR files and received the same error message each time. However, all of the same RAR files open fine when not trying to use Opus to view them.

***Please note: I did not rename the unrar.dll file in the Opus VFSPlugins directory at any time. I only renamed the other files that were not related to Opus. Additionally, I made sure to update the File Type settings for the RAR extension per the instructions provided in the FAQ article mentioned above (Events tab > Left Double-click > [added] Go command).

Did I miss a step somewhere? Could there be any other reasons why this feature isn't working properly?

FYI - I'm using a Windows 7 Home Premium 32-bit notebook PC with the latest version of Opus installed (v9.5.4.0.3806). I'm also using WinRAR v3.93 if that matters.

If I missed a post that includes info specific to my issue, I apologize in advance. I would appreciate any advice you may have to offer on how to fix this problem. I've wanted to get it sorted out for a while now and apparently can't figure it out on my own.

Thanks!


#2

Is it just that RAR file that won't open or all RAR files?

Create a test archive containing just a text file with a simple name like "Test.txt" (to rule out unicode/locale issues) and see if that opens.


#3

Thanks for the reply, leo.

The problem is with all RAR files. I only have a problem when configuring the "Double-left click" setting under the File Types "Events" tab with the "Go" command. If I leave it blank, everything works fine (all RAR files open) but they open in an external WinRAR window outside of Opus.

I also created the test archive you suggested (saved a text file as "test.txt" and then created an archive with WinRAR using the name test.rar). Like the other archives, it opens just fine - externally - via WinRar itself (and without using the "Go" command in Opus) but I still receive an error after adding the "Go" command and trying to open the same archive within Opus.

Here's an image of the error I receive:

I can't figure out why it's saying the archive is invalid or damaged when that's clearly not the case. I'm sure there's a conflict somewhere but I just can't find it. The only thing I can say for certain is that I tried renaming all the unrar.dll files as suggested in the FAQ article but that didn't work either.

Any other suggestions?

Thanks again for your help. You are an invaluable resource, leo!


#4

It looks like you've added .rar to the list of ZIP file extensions in Preferences / ZIP Files / Settings. If so, you shouldn't - what you're telling Opus to do is to treat a .rar file like it's a .zip file, which it isn't.


#5

Thanks, jon. You were absolutely right! Although, you probably already knew that. :slight_smile: I don't recall ever adding anything to the Zip file preferences but I'm sure the .rar extension didn't add itself.

With that said, I'm still experiencing problems when trying to open RAR archives. After removing the .rar extension as instructed in your message, I added the "Go" command to the RAR file type settings and, once again, tried to open an archive within Opus. This time, however, received the following error message:

Any thoughts as to why this is happening?

FYI - it happens on every RAR file, every time. Once the "Go" command is removed from the RAR file type settings, I'm able to open every archive - just not within Opus - only externally with WinRAR.

As always, I appreciate the help!


#6

Have you still got unrar.dll files all over the place? Now that the rar plugin is being used instead of zip, it's time to try renaming them again. Try the one in system32 first as that's likely to be the one that Opus is picking up by mistake.


#7

Sorry, leo. I should have mentioned that in my post.

Yes, I did rename all the unrar.dll files again - with the exception of the one in the Opus VFSPlugins directory. I renamed them, one-by-one, until they were all renamed as follows (in these locations and in this order):

* unrar.dll files renamed to unrar.dll.original *

[ul][li]C:\Windows\System32[/li]
[li]C:\Program Files\CD Art Display[/li]
[li]C:\Program Files\XnView\AddOn[/li]
[li]C:\Users[i]My Username[/i]\Desktop\Stuff\Antivirus & Malware Tools - This is just a folder where I keep a few shortcuts to some of my various antivirus apps. I have no idea why an unrar.dll file is here.[/li]
[li]C:\Program Files\K-Lite Codec Pack\ffdshow - There wasn't an unrar.dll file in this directory. However, there was a file named "ff_unrar.dll" so I renamed it as well just to be sure it wasn't a part of the problem (even though I knew it wasn't).[/li][/ul]
Again, I tried to open several RAR archives after renaming each of the DLL files in these directories. There are no other unrar.dll files on my PC that I can find.

I hope that extra detail helps. Please let me know if you have any other ideas.


#8

And the RAR plugin is definitely enabled in Preferences?


#9

jon-

Yes. I double-checked the settings under Preferences > Plugins > VFS. The only item listed is titled "RAR" and it is checked. I'm assuming that's what you are referencing.


#10

Hello, leo and jon.

Do you guys have any other ideas to share regarding this issue or should I send a message to the Opus support team?

Thanks.


#11

Here's something to try:

[ul][li]Download Process Monitor.[/li]
[li]Exit Opus. (Make sure you fully exit Opus).[/li]
[li]Launch Process Monitor and use Filter -> Filter (Ctrl-L) and set the filter to include Path Contains rar (see screenshot below). [/li][li]Launch Opus and double-click a RAR file.[/li][/ul]

You should get output in Process Monitor showing Opus open rar.dll, unrar.dll and the .rar file itself. Some of that may point to what's going wrong.

You can use File -> Save in Process Monitor to save the output to a file. Attach it here and I'll take a look at it.

Here's the filter screenshot. Important: Make sure you click the Add button so the new line appears in the list! It's very easy to forget that step. :slight_smile: