Problem with current multi-format archive plugin (vfs)


Some weeks ago the current multi-format archive plugin (vfs) of Opus 10 started to make problems with opening different archives (gzip, rar etc.) for some reason. Double clicking specific archives produces the following error:

I'm using

You can try this with

Is this problem reproducable? Is this just a configuration problem on my computer? Can someone explain this problem to me?

This error is really nasty!

Best regards,

The archive works fine here when I double-click it in Opus.

What happens if you try to load it into the 7-Zip program on your computer, instead of Opus? (Opus uses the same library as 7-Zip for opening .tar.gz files.)

What happens if you try to open the two archives below using Opus?

test.7z (133 Bytes) (154 Bytes)

Could your anti-virus be involved due to scanning/blocking the archives?

Have you tried reinstalling Opus (install it over the top of itself to avoid losing your config)?

What's the exact version of Opus that you are using? (And is it on Windows XP 32-bit as per your profile, or is that out of date?)

Sorry, I have to apologize!

You are right: Downloading this file via this forum link works perfectly now! Some minutes ago I downloaded it directly from the cpan website via Firefox and the two files are NOT identical. Downloading it now from the website works perfectly now, too. Something (Firefox, Antivirus app, proxy etc.) seems to have destroyed the file, but some bytes only! Both files, which you provided, work perfectly, too.

The strange thing is, that I got the reported error on a different setup at home (I'm currently at work) very often. I have to find the root cause for this first! If I need some help concerning this problem, I'll write again!

Thank you!

I tried to reproduce this behaviour at home but I mixed two different issues together: The problem described above is not a problem caused by the multi-format archive plugin.

The issue which I meant is the following:

Drag&drop subfolders within a previously opened RAR archive (in a lister) to another lister seems to make problems. I think this issue was reported here in "2." already.

An error occured copying 'subfolder':
The system cannot find the specified file. (2)

When I open a subfolder withing this RAR archive and copy one file only, everything is working fine. Is this config issue? Do you need some more information? I'll try to provide a RAR archive, which is generating this error. Or is this already a known issue?

It seems to be a problem with every RAR archive on my PC. I generated the following archive with WinRAR 4.11 :

Opus_Test.rar (573 Bytes)

Is the problem reproducable?

Thank you for your help!

From your descriptions, it's not clear exactly what operation triggers the problem. Can you give specific steps using the archive you uploaded as an example? What are you dragging, from where, to where... etc? I renamed your attachment back to a .RAR file, and could drag and drop files and folders from within the archive to another folder on my PC with no problems.

OK, no problem:

I'm double-clicking the RAR archive. The opus lister opens it and you see two subfolders and the file Clipboard.txt. Now select these three entries, drag & move them to another lister (let's say C:\temp) and drop it there. After that a message box is opened with the contents

An error occured copying 'apps':
The system cannot find the specified file. (2)

As you probably cannot reproduce this error, which mis-configuration could lead to that problem?

I'm in the middle of re-writing the way the archives plugin handles extraction, so it's probably best to wait until the new plugin version is ready and see if it still happens. If it does I'll take a look.

Strange thing:

I tried to reproduce the behaviour on the PC of my colleague and it's working without problem there. I don't know what I've configured on my PC, that leads to this problem...

Huuh! It's not a configuration issue! It seems to be a bug in your archive plugin:

Doing this with a dual lister is working without any problem :slight_smile:. As soon as you are using two single listers and dragging the archive subfolder from one lister to the other, the problem arises (even on the PC of my colleague).

Hmmm... Leo's suggestion of waiting til the new plugin is done notwithstanding, I tried it again with two separate listers as you suggested, and still cannot repro the same problem. Running v10.0.4.0 here... what version are you running?

Now that the plugin update is done, I've tried reproducing this but it works fine for me.

Svenni77, please try with when it's released (or with + the updated archives plugin now, if you don't want to wait) and see if it still happens.

If it does still happen for you, check which action your drag & drop command is running (copy, move, or something more exotic?) and which type of folder you are dragging into (normal local drive? something else?).

Thank you for the plugin and your message!

Your plugin seems to work now, I can't reproduce this error anymore. Opening a 7z file within a just opened rar file is not supported, am I right? This is the only conspicuous feature, I could discover, because it's not working.

Correct, nested archives aren't supported, except for .tar.gz and similar which are common and handled specially.