Problem with images inside a zip file?

Hello :slight_smile:

I only recently started using Directory Opus and I like it a lot.
So far I only encountered one "big" problem and I don't know yet if it's due to a limitation in Directory Opus or something wrong on my computer so I decided to post and ask other users :slight_smile:
Directory Opus seems to lock when generating thumbnails for images contained in zip files when "Thumbnail Threads" is set to more than 1 in the preferences (with the default value 2, directory opus lock up on my computer after generating a few thumbnails)
When the pictures are not in a zip file, thumbnail generation works fine and is very fast, even when set to 8 threads (the computer has 8 cores)

My configuration :
Windows XP 64
Dual Xeon X5365
16 gb memory

Thank you in advance for any infos and help you could provide :slight_smile:


Yes, I (still) have the same problem (only) with large zip files.
(posted about this issue here: [url]ViewerPane problem with large zip files containing images], problem never solved...)

I also have problems with the built-in zip handler, unfortunately:

  1. Some zip files cannot or can only be partially extracted. For an example, see and click on Download.

In my experience, the larger a zip file, the more likely that the problem will manifest itself, but I have not been able to determine exact steps to reproduce it.

  1. When adding files to a zip archive, occasionally the zip handler goes into an endless loop. It creates the zip compressed archive, adds all required files to it, then repeats the process ad infinitum (with the progress indicator pegged at 100%). The funny thing is that the zip file created in the first "iteration" is valid, it's just that Opus seems to repeatedly restart the compression process, creating temp files one after another (but there is always just 1 temp file, older ones are not preserved---presumably they are renamed to *.zip, always replacing the initially created archive).

  2. Several small hitches not worth mentioning before #1 and #2 are resolved :wink:

I really don't think any of this would be Jon's fault. Most probably the zip library is the one to take the blame, but anyway, I have to keep my old copy of Total Commander around just to handle problematic zip files... so it might be worth considering a switch to another compression lib (e.g. the one TC uses).

Thank you for the answers, now I know it's probably not due to my computer and I will stop scratch my head trying to fix it (I'm aware, my computer isn't exactly mainstream and some programs do have troubles with it :slight_smile: )
The weird thing is, I don't seem to have any problem zipping or unzipping files using Directory Opus, the problem only occur when I double click on a zip containing images to browse them and Directory Opus start to generate thumbnail for them. If I set the "content type" to disabled, all is fine (but obviously I can't see the pictures so it limits the interest. So, at least on my computer it really seems to be a zip + thumbnail generation problem (taken independently, both functionality (thumbnail generation and zip handling) appear to work fine.
I know how complex this kind of problem can be so please, don't see my question as a critic at all, I would really feel bad if my first posts here were to whine :slight_smile:


What kind of images are in the zip?

And is it it actually locking up... or is it perhaps taking a looooong time to extract images to temp file in order generate thumb (not sure if that's actually the process or not). I wonder if you do a test and let it just sit for a while if the thumbs will be generated and Opus 'unlocks'.

@ Nudel :slight_smile: :
Images are .jpg (zip files are between 40 and 120 mo, each one contain between 50 and 200 images).
@ Steje :slight_smile: :
I waited up to 2 minutes, and it really seems to be locked (in fact, even if it wasn't locked, 2 minutes would be way more than I'm ready to wait :slight_smile: )

As I said, I'm really not complaining, I can still use ACDSee for that (it has no problem reading those files and showing the thumbnails) I just think it would be nice to be able to do it from withing Directory Opus and I try to determine if it's a Directory Opus problem of if it's a problem with my computer (probably not hardware but maybe some other software "bugging" Directory Opus)


I also tested my problematic zip file again: Waited 6 minutes (DOpus.exe uses 99% CPU and 135.00 kB Memory) -> No Thumbnails appear.
When I exit the zip file, DOpus still uses 99% CPU... I have to exit DOpus.exe with Taskmanager.

(My configuration: WinXP; Intel Pentium IV 2,8 Ghz; 1GB Memory)

Christiaan, contrary to you I don't experience any increase in CPU usage, Directory Opus simply lock and I have to use the task manager to kill it (poor thing :slight_smile: ) But I run XP 64 so problems might well be different


Abrham, could you upload one of the problematic zip files (for example to and post the download-link here),
or are the images inside the zipfile 'for your eyes only'...?

No problem Christiaan :slight_smile: I work in the 3D industry (modeling and texturing) so they're a lot of files I can't really share but in this file they're only pictures I downloaded from the internet using google image so I guess it's ok (I need a LOT of picture reference so I have a lot of them).

If I navigate to this file, sometimes it will lock directly, sometimes I will be able to navigate a few time to it before any problem arise.

I store my pictures in zip files because it's much easier to have 500 zip files containing each 200 pictures in one folder than having the same amount of pictures in one folder (much lighter on the file system at least) so of course, being able to see those zip from within Directory Opus as if they were folders would be really great :slight_smile: For now I use XNView and I downloaded a trial of ACDSee, it works with both but I wish I could simply stick with Directory Opus only :slight_smile:


Do you guys have real-time anti-virus scanners set to scan inside of zip files? Perhaps the way Opus is opening the zips to generate thumbnails is triggering the virus scanners to scan the zip files (repeatedly?) or something?

Just a guess, but there's got to be a reason that some people see it but other people don't.

Nudel, can you check the zip file I linked earlier? Some of its files do not extract with Opus, and the reason might be the same thing that causes Abrham's problem.

(And even if it's not, there is most probably a bug behind it, which I will post in another thread unless it turns out to actually apply to this one as well.)

@ Nudel :slight_smile: :

No, I'm not much of a big believer in antivirus (in fact I tend to consider them the worst possible virus :smiling_imp: ) and since I only download pictures from the internet I feel pretty secure (firefox and thunderbird don't run active content unless I'm sure of the site).
I do have a firewall though (Outpost Firewall Pro ver. 4.0.1025.7828 (700)) and it has an antispyware but I turn it off .


@ Abrham:
I tested your zip file. On my computer I experienced no problems with your zip-file.
The thumbnails are generated instantly (tested with virus - scan On and OFF -> same results, no problems)...

@ Nudel:
I tested my own problematic zip file again with virus - scan (McAfee) OFF -> same problem occurs
(DOpus.exe uses 99% CPU and 135.00 kB Memory) -> No Thumbnails appear.

This is really weird that the same file don't produce the same problem everywhere. Anyway, I tried to reinstall Directory Opus and I still have the same problem (with every single zip containing images in fact) so I guess there is something wrong with my computer :slight_smile:

Abrham :slight_smile:

I decided to reinstall my computer from scratch (after creating an image in case it would be useless :stuck_out_tongue:).
So, I reinstalled windows (xp 64), all the updates, my drivers and right after that, Directory Opus. After that I tried to browse my zipped folders containing images and .......... it works :slight_smile:. Even when I set Directory Opus to use 8 threads (the 8 cores of the computers) it works (and then, damn, it's fast :smiling_imp: )
So, I guess I have to apologize, the problems I had was most certainly due to a bug in Directory Opus but much more probably something it didn't like in my system :slight_smile:

Abrham :slight_smile:

I couldn't find a button to edit my post :frowning:
The last sentence should be :
So, I guess I have to apologize, the problems I had was most certainly not caused by a bug in Directory Opus but much more probably something it didn't like in my system Smile

I'm aware the thread seems to be dead now but I still post this info, maybe it can be useful to someone :slight_smile:
So, the problem reappear after I install Outpost 4 (even with the spyware turned off and all right given to Directory Opus), if I switch to Outpost 2008 everything works fine again. So, there seems to be something in Outpost 4 that "annoy" the zip functionality in Directory Opus :slight_smile:

Abrahm :slight_smile: