Problem with simple zipping command

Somehow, I cannot construct the command that would move all selected files to a zip files with the filename provided in a dialog window (and WITHOUT specifying the path).

Such as:

Copy MOVE here zip as="{dlgstring}.cbz"

I have tried both zip and addtozip, however, none of them allow automatic (via custom dialog) specifying of the filename... The dialog addtozip presents is no good, as it does not allow an extension different from zip.

I guess I can rename the file afterward, but it seems a roundabout way to do it...

Instead of AS use CREATEFOLDER.

It works exactly the same... With zip I get a, with addtozip I get the regular dialog...

What's the full command you are using?

I started with the one given above, i.e.:

Copy MOVE here zip as="{dlgstring}.cbz"

Then I tried addtozip instead of zip and createfolder instead of as... Still I do not have the result I'm seeking (i.e. moving all selected files into a zipped file with a specified name, without the path selection and standard zip dialogs displayed).

Yes, so show me the actual command where you have tried CREATEFOLDER instead of AS.

I am sorry, but I think I do not understand your question...

I use a button and tried the following combinations:

Copy MOVE here zip as="{dlgstring}.cbz"
Copy MOVE here addtozip as="{dlgstring}.cbz"
Copy MOVE here zip createfolder="{dlgstring}.cbz"
Copy MOVE here addtozip createfolder="{dlgstring}.cbz"

None of them do what I would like them to do...

For me,

Copy MOVE HERE ZIP CREATEFOLDER "{dlgstring}.cbz"

works fine, as long as .cbz is added to the list of recognized ZIP file prefixes in Preferences.

Hmm... For me it does not...

When I use the command you have specified (I have added cbz to the extensions) and select e.g. files "1.jpg", "2.jpg", "3.jpg" and press the button, I still get the file "" (no matter what I put in the dialog).

Are you using Opus That's the first version where CREATEFOLDER works with zips.

Good point :slight_smile:

Very good, indeed!

I have somehow missed the update... Now it works correctly, thanks!