Problem with the Dopusviewer stops working

I have had this problem often on for a long time. I've installed the latest Adobe reader, my Acrobat is up to date. When this happens it completely messes up my work. I'd like to know how to make it stop, here is the app crash print out

image

Gary Aksland Manteca, California USA

Is it only when viewing PDF files?

Does it also happen if you view the same file in File Explorer's viewer?

The PDF viewer crashing will usually be due to the PDF viewer itself (Adobe Reader, if that's what you're using) and not the Opus viewer.

If Adobe Reader is crashing for you, changing to another PDF viewer is one option. Sumatra is a free one that includes a preview handler which works with Opus, as long as you choose that extra component when installing it. PDF-XChange is another option. I think FoxIt may have an official preview handler (or if not an unofficial one), but it's a while since I looked at that one.

It happens with ALL files types, it's like the viewer had a brain fart. I have had this problem of and on for a long time, the updates dont seem to address it. But it is not only pdf files. If I restart dopus sometimes that fixes, otherwise I have to boot my computer, a real pain.
Gary Aksland

Not all file types will invoke docswv32.exe. Which types are you seeing the problem with, specifically?

What happens when you view the same files in File Explorer's viewer?

Now that I think about it, maybe the PDF file initiates the problem, but the viewer remains nonoperational after this happens. Turning off the program and restarting, sometimes resolve the problem, but it doesn't last that long. Sometimes in a three-hour period I might have to shut down and restart the program 5 or 6 times. So maybe your original suggestion that I should attempt installing Sumatra as my PDF viewer. Thank you for your suggestion, one other question every time I restart the program, I would like to know how to have it come back to the same directory settings, is when I closed it, is that possible? I use this program all through the day, and I reccommended it to many of my friends, thank you for your time.
gAksland

The settings under Preferences / Launching Opus can do that.

Preferences / Launching Opus / Startup / Open the Listers that were open when the program was last closed may be what you want, or Preferences / Launching Opus / Default Lister / Update Default Lister automatically when closing a Lister, depending on exactly how you want it to work.

Note that if Opus crashes or is killed (e.g. via Task Manager) then it won't always have updated that information.

Hi Leo, I am still locking up 5-7 times a day, Please look at the 2 images and see if you have a suggestion
DopusFreezingIssues.zip (289.0 KB)

Have you tried using another PDF viewer? Or reinstalling/updating the PDF viewer that you do use?

When docsvw32.exe crashes, it's because the third-party viewer loaded into it has crashed. At best, we can sometimes work around such crashes to avoid triggering them, but the actual problem is in the third-party viewer component that is being used when the crash happens.

This is not directly related to your problem, but it might be worth a shot just to eliminate Opus as the source of your problem.

I have had endless difficulties with putting PDFs into OneDrive via Opus. It drove me insane for quite a while. Then like you I began to wonder whether it was the actual PDF files that were causing the problem. I collected a few "problem files" together and embarked on trying to "fix" them.

I discovered that most could be "fixed" and sent to OneDrive by re-saving them from Acrobat.

Others need to be opened in a PDF editor and re-saved as PDF-A (Archive Files)

Still others needed to be run through a PDF optimiser program.

That got me through my OneDrive problem and showed that Opus was not involved. Of course my problem and yours are poles apart, but it may be worth a try, if only to eliminate some issues.

Hi Leo,
Is there a "safe" place to update active X, I am currently running w7 ultimate, but moving to W10.
Gary

I'm not sure what you mean. ActiveX is a protocol, not something you can update. The ActiveX+Preview+Office+Web plugin comes with Opus and is updated with it. That plugin is not what is crashing, though; your PDF viewer is. Adobe Reader or whatever you are using. That is what you need to update, repair or replace.

Ok thanks Leo, I recommend Dopus to my friends, it's just that having to re-start 5-10 times per day is a REAL pain in the ass. Maybe when my move to my new Dell precision 7720 work station lap top with W10 things may improve.

Have you actually tried fixing the PDF viewer?

The problem you are having is with your PDF viewer. It is not with Opus.