GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Problem with (usb-)Hardware disconnect

Disconnect an usb-harddrive is not possible cause opus uses that device.
Problem is that Opus Helper Application ( Dopusrt.exe) is still active.
Is it possible that OR to terminate Dopusrt.exe after a specific not-used period, OR to release opus-fingers from taht USB-device?
My solution is, terminating the Dopusrt.exe task, by task-manager.

The DOpusRT.exe that stays running just waits for desktop double clicks and should not even be accessing a USB drive.

Are you sure that process is involved?

How are you removing/ejecting the device?

Dopusrt.exe is just visible in Taskmanager, the only place where I can stop it. After stopping, removing device follows its normal procedure, without any troubles.

Are you running Opus from that USB device, e.g. as a portable install?

1 Like

Nen ik gebruik vanaf mijn PC. Mijn backup-device is een USB-harddisk

If you select Preferences / Launching Opus / From the Desktop / Disable then that should close dopusrt.exe and it should no longer run in the background (except to do short-lived tasks, where it exits immediately afterwards).

It would be interesting to find out if the problem still happens after you've done that, and which if so process seems to have the lock then.

The only way dopusrt.exe should be locking a drive is if it was run from the same drive, or the current directory was that drive when dopusrt.exe was launched (which would be quite unusual).

Leo, dank voor uw onuitputtelijke geduld!
Ik heb Voorkeuren/Opus starten/ vanaf het bueraublad/uitschakelen geselecteerd.
Ik heb Opus gestart vanaf de taakbalk, opus is gestart, opus helper is in de systemtray verschenen.
Je kunt nu opus beëindigen, of door de functie van opus helper,
of, door de kruis rechts-boven in het scherm.
De eerste optie laat én het programma, én de helper van het scherm verdwijnen, maar de helper staat nog wel in taakbeheer.
De tweede optie laat opus van het scherm verdwijnen, maar helper blijft in systemtray staan.
Er is dus wel verschil, maar het probleem nog niet opgelost.

(Please post in English, as most people who might be able to help won't read the post if it's in Dutch. Google Translate is fine.)

If dopusrt.exe is running even with desktop double-click turned off then something strange is going on.

If you look at dopusrt.exe in Task Manager and turn on the Command Line column, what does it show?

I am sorry, but where/how can i find the commandline in Task manager?

Right-click the columns header and choose "Select columns".

Sorry Jon, I guess I need more specific instructions to understand how I can find what you need.
Click on "the" column is too difficult for me..
I tried, but I can not find the same thing as you send me on the screenprint...

The column header, e.g. where the red circle is:

image

I guess you are looking for this.

Is Preferences / Launching Opus / From the Desktop / Disable definitely selected? That process should not be there if it is.

I am very sorry!

I changed the disabeld function, but I did NOT notice that it should be confirmed!!

Therefore.... You gave the correct solution!
Thank you