Problems with searching files in a Cryptomator vault

I just switched from BoxCryptor Classic to Cryptomator for my encrypted file vault, and it seems like DO (version 12) is having problems searching in a mounted vault. Even something like *.* does not match any files, the "Find Results" tab stays empty. Are there any known problems with searching such "virtual" drives? Windows Explorer or grepWin do not seem to have any issues finding files there.

Try a search for * rather than *.* and also make sure no other criteria are turned on in the Find panel.

(Assuming we’re talking about Tools > Find Files.)

I've "Reset" the "Simple" search in the "Find Panel", and I've tried *, still no matches. Now here comes the funny thing: I do get matches if I'm searching from the root of the vault, then also something like *.dotx returns matches. However, if I change into a top-level directory for which matches were returned before and search within that directory, no matches are returned. So, for example searching in V:\ returns match V:\Docs\Work\a.dotx, but searching in V:\Docs does not return that match.

Only way I can think that would happen is if the drive (or folder permissions on it) won't return directory listings for the root, Docs or Work levels. (Or if anti-ransomware or similar is censoring the directory listings because it thinks something sensitive is included in them and doesn't trust dopus.exe to see it.)

Opus knows nothing about Cryptomator and uses basic Windows APIs to request directory listings on it, the same as any other drive, so the difference is likely to come down to how something outside of Opus is responding to those API calls.

I'm not doubting that it may not be DO's fault, but still it would be interesting to know why it only happens in DO, and not with Windows / File Explorer, grepWin, or Agent Ransack. I also realized that DO's search stops suspiciously quickly after clicking on "Find" for V:\Docs, as if indeed some enumeration API would return no files / directories. If you could spend some (boxed) time if would be good to know if you can at least reproduce the issue, and maybe get an idea where to dig further.

Can you actually read those folders in Opus? E.g. if you go to V: and double-click Docs, do you get a directory listing?


It’s probably a bug in Cryptomator, similar to this one:

For the record, Cryptomator uses WinFsp, and changing the mount from "Autodetect" (which seem to be a WinFsp network drive) to "WinFsp (Local Drive)" in the Cryptomator preferences makes the issue go away.

1 Like

I've reported this to Cryptomator.

1 Like