Problems with tearing and continously auto-refreshes in tiles mode after updating to 12.2.5

Sure, send the zipped native PML format log to and I'll take a look.

(CreateFile is normal; that's used for both reading and writing.)

Thanks for sending the log file over.

The log file shows change events seem to be coming in for some files in the folder, but didn't give any solid indication of what was triggering them.

A couple of things to try:

  • Disable the Movie plugin. (Preferences / Viewer / Plugins.) That's the only thing I can see opening files for writing, but it's not actually writing for them. (It's just checking if anything else has them open for writing, and closes them immediately. Shouldn't trigger notifications, and wouldn't explain why they're happening for non-video files. Still, worth ruling out its involvement.)

  • Uninstall TSVN, as you suggested in your email. I'd be surprised if it is involved, but it is accessing the folder at the same time, and it is something that can trigger shell change notification events, so it's not completely impossible. Worth ruling out, at least. Be sure to reboot after uninstalling it, as it won't be fully unloaded until then.

  • Enabling the Debugging steps near the bottom of here and seeing what they indicate may prove useful. Knowing more about what the change events are may help understand where they are coming from.

The only other thing I noticed from the log is that the folder is below C:\ but some of the low-level function calls look related to network drives. It's possible that is normal and just something I've never noticed before (maybe Windows routes everything through a generic function, for certain operations). On the other hand, if there's anything unusual like a junction or symlink that is pointing the folder or a sub-folder to another drive or a network drive, then that might be an important detail.

FWIW, I tried again with your config but still can't get it to happen here. The information in the tiles moves up and down once when the extra info is populated, which is normal, but it does not endlessly/repeatedly refresh for any of the files.

Hi Leo,

Thank you so much for your detailed help, much appreciated!

I already tried disabling all viewer plugins in earlier tests, cause me too thought it could be related in the refresh issue. Unfortunately, it didn't help.

I tried it now. Uninstalled TSVN completely and rebooted. No difference, same issue.

I've created a logfile. Because logs are very dopus related you'll probably see much more than I do. Hopefully there's something there that helps. I've send it to you by mail.

Regarding junctions and links: I wasn't aware of any junctions or links in this folder, but you never know. So I used the Dopus find file function and searched for filetype: "Junction and Links". No hits.

I don't have any network drives nor shared folders on this machine. However it's a delevopers machine and there are many Sony tools installed. They're mainly for supporting the connected PlayStation DevKits, but now you mention it, there is one tool that installed a low level file driver. This allows browsing memory cards like any other directory. I think it's based on the dokan file system library.

I couldn't see that this is involved in any previous logs, but if you think it might be worth to give it a try, I'll uninstall this library too, just to make sure that this isn't the cause:

Besides VS 2013 is installed, which is also some kind of software octopus:) I think installing this suite alone installs up to 15-20 additional projects and components like SQL-servers, .net stuff and so on. But still, it shouldn't cause such issues and I think you guys are working with VS too.

Thanks anyway for taking the time to check and for all your help. Hopefully you'll see something helpful in the log.

Kind regards,

Hi Leo,

Could you get any insights from the log?

Kind regards,

Nothing from the quick look I had a while ago. It's still in my queue for a more detailed look, but fixing the forum has taken up most of my recent time.

Whatever is going on looks like something unusual triggered by something external to Opus which keeps generating events telling it the files have changed. Looking at any tools & shell extensions involved in the file formats being changed might be worth doing while waiting for me to get back to it, if it's causing problems.

Hi Leo,

Could you please explain what steps are required for that? I'm not sure of what you're talking exactly. Thanks.

In the meantime, I tried a different approach, but not sure if it makes sense, so please let me know, if it's nonsense :nerd:

Just took the logfile from DebugView and deleted all lines that are not a file/pathname. Then I sorted all lines of the file. In the last step, I was looking for duplicate lines.

The outcome was, that there are 73 duplicate lines from ~2300 lines. Could this be involved in the multi refresh triggering? Or am I completely wrong?

Kind regards,

You could use ShellExView and disable anything with Type =

  • Column Handler
  • Icon Handler
  • Icon Overlay Handler
  • MetaData
  • Property Handler
  • Thumbnail
  • Thumbnail handler

Uninstalling software that's installed and related to the file types having problems is also worth a try. Especially anything that has shell extensions (in the ShellExView list) or which monitors folders to maintain a media library or a search index/cache.

Similar with asset management or source control software, which might scan files/folders and can generate change events to signal their their source control icons need updating.

From the log it looks like the problem is happening on C:, so not likely to involve a NAS or other type of network drive (which sometimes have issues with spurious change events triggered by reading files), but if anything exotic is involved, such as junctions/symlinks that point to files/folders on other drives than C then those are worth investigating/mentioning.

From another look at the Process Monitor logs, and filtering dopus.exe out to see what else is going on (since the problem seems to be another program generating "this file has changed" events for lots of files), a couple of things look worth looking at:

  • TSVNCache.exe from TortoiseSVN is scanning some of the files. It can also generate events to tell programs to update their icons. Maybe something is going wrong and causing it to repeatedly generate events. Try uninstalling it to see if the problem remains with it no longer there.

  • A service is running which accesses C:\ProgramData\BullGuard\LogData\BsMainLog.db a lot. Looks related to an antivirus product. It might be wroth a try to uninstall it and see if it's involved.

  • The Windows Search Indexer is doing its usual stuff. Turning off indexing might be wroth a try, in case it is the trigger. (If it is, it's likely in conjunction with something else that has installed an extension, but first just see if it's involved at all.)

None is definitely involved, but they are worth ruling out.

Be sure to reboot after disabling or uninstalling anything as the DLLs involved tend to stay around until the reboot.

Hi Leo,

Many thanks for your reply.

I'm aware you have to handle hundreds of issues here, so you can't keep track of everything, but we already went through all the topics you have suggested. (Feel free to check earlier posts in this thread)

Especially SVN, antivirus software and windows search index service has been disabled with no change. (Reboots have also be performed)

Is the hint with the duplicate lines from the DebugView log of any use for you?

Kind regards,

Have you tried disabling everything with ShellExView?

Hi Leo,

Yes, see here:

[quote="Skeeve, post:18, topic:24033"]
As adviced, I started disabling all icon and image relating app and system stuff with the ShellExView tool. I was trying to do this one by one and testing at the same time, but ended up by disabling everything, including all MS windows and shell32.dll extensions, although the tool showed some warnings and didn't recommend this.

It was definitely disabled, the right click context menu was almost empty, beside some standard Dopus entries.

However, it didn't help at all. Even with all shell extensions disabled, this still happens.[/quote]

Kind Regards,