Questions

Hi, I'm evaluating DO and it seems by far the best file manager around. Just a couple of questions, though.

  1. When in List or Thumbnails mode, the Inline Rename function doesn't work. No setting for it in Preferences either. Is it so, or is there some special configuration needed?

  2. When starting DO each session, I've noticed that it keeps the system busy (very busy) for quite a long time, as if it's searching (or caching) all the files. Is there a way around it, since it affects the functionality of other programs.

Thanks for any answer.

For question 1: Switching to either of these views for me still allows inline rename ( key?) to work fine. I'm not aware of any settings that could affect the keybinding for Inline Rename just because of what view you're in. I would suggest opening a ticket through the GPSoft support site if nobody else has any ideas here on the forums.

For question 2: When you say "When starting DO each session" do you mean at boot time or each time you open a new lister? Or are you generally exiting the Dopus program entirely via the system tray icon - right click and "Exit" before re-launching from a shortcut...? Others will probably also inquire if you have any file collections, what plug-ins are enabled, and what your starting folder is when you open Dopus depending on what your anwser is about what you mean by 'starting each DO session'.

Hi. Thanks for answering.

Regarding question 1, I've tried the F2 key, and slow kicking the file twice. The inline rename [brackets] appear for a faction of second and then disappear. I can only change names through the rename dialog.

And I've found the reason for question 2. It's because I had turned on the option of 'Calculate Folder Sizes Automatically...' in the Folders' Option in Preferences. It seems that DO automatically calculates the sizes of ALL the folders in my computer beforehand. And since I have a lot of files, it takes more or less 10 minutes to finish the task. I tuned the option off and no more problem.

As to the plugins, I don't have any problem with them. They work great. The system works in the same way with the plugins turned on or off. No ursurping of memory or CPU capacity.

Thanks again for answering.

Sure, and oops, I forgot about the calculate folder sizes thing too. A common 'startup' utilization thing (I also have this disabled).

For the inline rename thing... one thing I've often come up against is indeed the 'fraction of a second' rename highlighting, then it goes away. I've found you don't want to get too 'happy' with 'both' the key and the slow doubleclick... but have not seen this specifically in a particular view - I mostly ALWAYS use details view. So if you highlight a file, and move your hand completely off the mouse... make sure the file is not in 'rename' mode and hit it just plain old doesn't work?

I too have this problem while in Thumbnail mode. Once I upgraded to ver 8 I no longer am able to rename files while in the Thumbnail mode.
Did you find a fix for this Sein?
Thanks

I discovered the reason for I why I have been unable to rename a file by pressing F2 while in Thumbnail mode - I use a Logitech MX Laser mouse and whenever the cursor is hovering over the Lister when I press F2 the inline rename displays only briefly. But if the cursor is hovering over the Folder Tree, inline rename becomes possible again. As soon as the cursor moves back over to the Lister the inline rename reverts back and renaming the file is no longer possible. I still don't understand it but at least I'm not left in the dark as to what is causing it. The same problem does NOT occur with Power Desk ver. 6 or Windows Explorer, however.
I hope this may help with someone else experiencing the same problem.

For what it's worth, I've got a Logitech MX1000 mouse (along with its terrible drivers -- what was wrong with the old mouse drivers, Logitech??) and I can't reproduce this, with or without the mouse being over the folder tree. Maybe I'm missing a step?

If you're having the problem can you go to Customize, Keys and check what F2 is set to? It should be this:

rename inline

Also I'm assuming nobody having the problem is using a keyboard with F-Lock where F2 doesn't send F2 by default... :slight_smile:

Strange, really!

I tried what Typo said. First I selected the file (or folder), then moved my mouse (a Microsoft IntelliMouse) over the designation area, then pressed the F2 key and, voilá, no problem with the inline rename at all! I can even do it when I slow double click on the file and move the mouse quickly to the designation area.

It's the first time that I can rename a file in List or Thumbnail mode without invoking the Rename Dialog. Strange indeed. And it doesn't work when I move the mouse outside of the Lister.

It would be great if someone could provide an answer for this behavior.

nudel, the F2 key function is indeed set to “rename inline”, and no…no F-Lock, but please keep the suggestions coming as I would like to find a solution.

I tried using my Microsoft intellimouse and it too had the same problem, although I did not take the time to uninstall Logitech’s drivers so it probably doesn’t demonstrate anything. The other very annoying problem that I encounter is that when I scroll (using the mouse wheel) either the Lister or the Folder Tree both scroll simultaneously - not always but often, especially when I begin scrolling in the Lister and then move to the Folder Tree and begin scrolling. I normally attribute this behavior to lousy software but I know Dopus isn’t designed to do this and that the problem lies with some other quirk. The simultaneous scroll does not occur in either PowerDesk Pro or Windows Explorer, which leads me to believe that Dopus and the mouse interfere with one another. I was beginning to think that the fault lied with the MX1000 mouse but seeing as nudel has an MX 1000 with no problem and sein has an intellimouse with the same problem I’m not sure what to think.

It would be good to figure this out as other people are likely experiencing similar problems and this behavior would be a big turnoff if I were evaluating Dopus for the first time and didn’t know it was an anomaly.

I'm suspect the "two windows scrolling at once" problem isn't Opus but is Logitech's awful new mouse drivers.

I think I've seen the same thing happen with Firefox and mIRC (scrolling a webpage also scrolls one of my IRC channels), although I can't be sure it wasn't Opus and mIRC (which I've also just seen).

It's very annoying, and only started happening after I upgraded from an MX700 to an MX1000 and thus was forced to use SetPoint (boo!) instead of MouseWare (yay!).

I can't work out a reliable way to reproduce the problem. Seems to be something to do with one window having the input focus while the mouse is over another, then using the scrollwheel. If I could reproduce it at will I'd report the problem to Logitech (unless I could only get it to happen with Opus, in which case I'd hassle Jon & Greg to investigate :slight_smile:).

Regarding the inline-rename weirdness, presumably none of you guys experiencing the problem have anything installed/enabled which changes the way the input focus works. e.g. A program which lets you type into the window where the mouse is pointing. TweakUI has an option called "Activation follows mouse (X-Mouse)" which would definitely cause inline renaming to fail if the mouse wasn't pointing at the file display.