RAR extract access problem


When updated opus to 10.1 my rar extract buttons stop working.

button code:

"C:\Program Files\WinRAR\WinRAR.exe" x "{f}" "{o|noext}\"

When i use it i get error:
! C:\Users\Kondi\Desktop\GPO for Home version systems.zip: Cannot create Gpedit Installer.exe
Access is denied.

With what user context opus run this command ?

Nothing should have changed that would affect that.

What happens if you run the same command via a command prompt, or using WinRAR's GUI, instead of using Opus?

The command is run in the same context as the lister. If the lister is UAC elevated (via the Admin Mode button on the toolbar, or @admin in the command) then it will be run elevated; otherwise, it runs in the normal context that dopus.exe itself is running in.

When i click extract button from windows (desktop) context menu, winrar extract without any errors.
Maybe it's a time to switch my extract button to built-in extract command ? Is the performance built-in extract was improvement ? (when i tested it long time ago the performance was worse then winrar extract )

Is that doing exactly the same thing, though?

At the end of the day, Opus is just launching WinRAR with a command line so I'd expect the same error to happen if you extract the same archive in the same way, to the same destination. Unless there's something wrong with the command line.

Hmm, actually, there may be something wrong with your command. You're putting the quotes in explicitly, around the {f} and {o|noext}, but Opus will also put extra quotes around those things if they contain spaces, unless you add @nofilenamequoting to the top of the command. So maybe it worked in the past because you never selected a file with a space in its name or path, but today you're trying it with one which has one.

Give this a try:

@nofilenamequoting "C:\Program Files\WinRAR\WinRAR.exe" x "{f}" "{o|noext}\"

There can also be some weird things with command line programs and arguments that end in " because it gets interpreted as a single (escaped) " instead. So if the above still doesn't work, this might fix it, with an extra \ near the end:

@nofilenamequoting "C:\Program Files\WinRAR\WinRAR.exe" x "{f}" "{o|noext}\\"

We use the 7Zip library to unrar things these days, and that in turn uses the unrar code from the maker of WinRAR.

I think the very recent 4.xx versions of WinRAR gained some speed-ups which haven't made it into other libraries yet, so it may be faster, although I don't know if it is or by how much. The unrar in Opus 10 should be faster than it was in Opus 9, though, so it might be worth trying to see what it's like compared to what you're used to.

Both solutions won't work (error: cannot create folder)

Never mind... I switch command to built-in extract, because it's much much faster then it was in Opus9

Thanks Leo,