Refresh Network Drive

When you create a new file/folder (i.e. extract from ZIP or PASTE) on a local drive the new file/folder will appear immediately. If you do the same on a mapped network drive you need to refresh to make the new file/folder appear. Is there a way to make the network drive behave like a local drive?

EDIT: I shouldn't have used PASTE as an example since that does work. But when a program creates a file it won't appear in the current folder you are viewing on a network drive until you refresh.

You can enable file notification on network drives through Preferences (File Operations - Detect external file changes on network drives)

Note that some networks (e.g. older versions of Samba) simply don't support file notification, or report changes very infrequently, so you will still have to press F5 for these.

Thanks jon. I guess it's my Samba version. I'll just keep pressing F5.

If you have control over the Samba server, it may be you just need to configure it to enable notification. In the same place you can configure how often it polls the remote file system for changes (the default is quite high, 2 minutes or somthing crazy, last time I looked).

I'm not sure if Linux/Unix filesystems just don't do notification (hence having to poll every x minutes/seconds for changes) or if Samba just doesn't use the feature and opts for polling for some other reason.

I can't claim to be an expert on Linux or Samba; I just investigated some of these issues because we have a Samba server at work that we needed to see new files on as they were created.

Resurrecting this thread from the past... :slight_smile:

I am trying to get notification to work in Opus 8 on a Samba server. I have FAM installed on the server, and Samba is using it OK -- it's working fine in Explorer windows; If I fiddle with files on the server it's self with an Explorer window open on the same directory (UNC), I see them update. Opus, however, does not.

I've tried on both a UNC path and by mapping it as a drive, but it doesn't seem to work on either.

I do have 'detect external file changes on network drives' turned on but that hasn't done it.

Anything else I'm missing?

If you make the changes in Opus do you see the updates in Explorer?

If so, there's a FAQ on diagnosing this problem. Go through that and let us know what you find.


I did go through this: [url]Changes to folders are not being detected] if that's the one to which you refer.

When I tried yesterday, turning on debugging didn't seem to reveal much; A lot of notifications on other random things (like my NTUSER.dat file, the registry, etc.)

However I just turned it back on and now I'm seeing:

Notify 16956f0 Returned 0 bytes, error 59

that correlate to me copying/changing files on that share in Explorer (or Opus). Maybe I just missed them last night in the mess but that's what I'm getting now, anyways. There are no other lines referring to a path that come out simultaneously like others.

I'll zap a note off to support since I'm actually getting a tangible error message now.[/url][/quote]

Well, doesn't work for me neither in v9.1.0.0. I made a little video, which demonstrates the single steps to reproduce the behavior.

Scenario: I created junction points within my profile folder, which point to some shares (and also supershares) on my server. Renaming a file or copying a file to that location using dopus is viewable in the windows explorer immediately, but in DOpus only after pressing F5. The "Detect External File Changes..." option is turned on. By the way: This all also happens with network drives instead of junction points.

In the video I waited for a couple of seconds after renaming or copying before I pressed F5. Download the file HERE (ca. 5 M).

The attached screenshot shows the output of the DbgView utility. The red lines appeard directly after pressing Enter when renaming. The green lines appeard after pressing F5.

Note: There's also another video with a few comments. You can download it HERE (ca. 45 M). All the stuff is on my server with a max of 800 KB upload (sorry).

What kind of network share is involved? Windows? Samba? Which version?

If you haven't already then it's worth opening a Support query with GPSoft and pointing them towards the information you've provided here so that they can investigate.