GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Refreshing network drive letters


#1

Situation:

Folder tree has some network drives mapped, for instance:

Home (\MYNAS)(H:)
Photos (\MYNAS)(P:)

When I go to the IP-address of my nas 192.168.0.253 in DOpus I get a list of available folders. When I right-click on Home, choose "Make Network Connection", chose the same drive letter as the one I already have for it (H:) and confirm if I want to replace the current drive letter, the network connection is made succesfully. However, the line still reads

Home (\MYNAS)(H:)

while it is actually

Home (\192.168.0.253)(H:)

So what's missing is a refresh.
Disconnecting H: first and then creating the new connection ofcourse does work.

Replicating this in Windows Explorer results in exactly the same thing, no refresh either. Guess DOpus is getting it's drive letter info from that and it's a Windows-issue?

Thanks.


#2

If Explorer does the same thing then it's unlikely to be an Opus issue.

Where does that menu item come from, though? It's not there normally for standard mapped network drives.

I see a "Map network drive" menu item (slightly different wording, so I'm not sure if it's the same thing that you're seeing) when I right-click a share, but that will not allow me to choose a drive letter which is already in use.


#3

If you pick one that's already in use you get a question if you want to replace the existing mapping with the new one. When you do, that's where appearantly Windows messes up.


#4

I can't pick one that's already in use. The letters which are in use are not available to select:



#5

That's weird, I can:



#6

Apologies, my mistake, it does offer other mapped drives, it just excludes letters used by non-network drives. (I could swear it was different when I tried earlier, but I must have tried the wrong thing. It works as you describe now, either way.)

Still, the underlying problem is (as you suggested) most likely that Windows isn't sending a notification about the change since both Opus and Explorer are affected.

Interestingly, if you fully exit Opus and then re-launch it, you get the updated label, so perhaps the Windows API caches network drive labels for the duration of the process or similar, unless they are disconnected before being changed.


#7

Guess I'll just wait for my computer to be rebooted. It's not that important as long as it works.

Thanks for clearing that up :slight_smile: