Refreshing problem with external usb-drive

I tried to reproduce for debug, but since restart of Vista it works fine (as I said: random :confused:).

I'll report soon (must copy lots of gigs next days)...

I have noticed that I can not shutdown the USB Hard drive as long as any of the Dopus.exe's are loaded in RAM. They just won't let go so you can unload and power down the device. That is true even if all listers are closed. USB Ram drives are no problem at all.

Opus 8 or Opus 9? Which version of Windows?

[quote="Sasa"]I have some external USB-Drives, formated with NFTS.

Since minor DO9-Updates the lister doesn't refresh after copying files on the external drives. It worked before with DO or[/quote]

Maybe this is the same problem as I have.
I have a 500GB USB external IDE drive on an XP prof dell laptop
If I make a change using DO, the lister will show the change.
If I make a change outside of DO (dos or other program) then it won't show.
Happens under both v8 and v9
I can fix the problem for a while by rebooting the computer.

If I use explorer, the change will show.

When I first started using DO v8 last year this problem did not occur. I think a windows update may have broken this.

Sorry, I didn't see the other post.

So it is a known problem if the drive is connected after DO is started

[quote="takarada"]Sorry, I didn't see the other post.

So it is a known problem if the drive is connected after DO is started[/quote]
That's one theory that some people have, but it isn't like that for everyone and I don't think GPSoft have ever been able to reproduce it. Opus 9 has some changes which should help in this area but it seems, from threads like this, that some USB devices (or USB filesystem drivers) still cause the problem sometimes.

The best way to help solve it is to go through the debug steps in the FAQ and report back what you see:

[Changes to folders are not being detected)

I find this to be completely reproduceable.

I copied a file in dos before the usb drive was disconnected

Notify 19a8d28 Returned 28 bytes, error 0
Change 1 to L:\temp\test.jpg
Notify 19a8d28 Returned 28 bytes, error 0
Change 3 to L:\temp\test.jpg
Notify 19a8d28 Returned 28 bytes, error 0
Change 3 to L:\temp\test.jpg
Notify 19a8d28 Returned 28 bytes, error 0
Change 3 to L:\temp\test.jpg

Then disconnect and reconnect L:

I copied the file again in dos to a different filename.
No change was detected and the new file does not show up on the lister
But many changes where detected on c:, firefox/McAfee etc

I am not asking for a fix, I just needed to know that I should restart opus.

[quote="takarada"]I find this to be completely reproduceable.

Anything interesting in Event log?


Do the changes get detected by [url= Monitor[/url], if you start it at the same time as Opus, or are they hidden from it as well?

The change is detected
Here is one line from the process monitor
6475 07:52:34.5452554 cmd.exe 3920 CreateFile L:\temp\test1.txt SUCCESS

But the lister still only shows the original file test.txt
This is on

I tried the test on 9 but I also had to restart DOpus to detect changes
Changed made BY DOpus are detected in both versions

Anything else I should check?

Nothing else that I can think of. The best thing you can do is contact GPSoft via their support page and see if they can get to the bottom of it. If you can consistently reproduce the problem then that's a start as GPSoft and friends such as myself are unable to do that.

So if you disconnect and reconnect a usb drive on your pc opus still detects changes on that disk made outside of opus?

If I do that my PC bluscreens because the BIOS/drivers/Vista/some-combination-of-the-above is ****ed. :slight_smile:

But yes, on other machines it works fine and Opus still sees changes on that drive.

Hello, has anybody found a solution to the problem in the meantime?

My configuration is

win xp sp2
500gb external USB hdd, ntfs, (Western Digital MyBook)

The bug is reproducible to the extend that it occurs, as far as I see, almost all the time. (Might be it only occurs in sessions after hibernation, not reboot, but I am too lazy to check this at the moment.)

The bug makes Opera practically useless when mainly operating with files on an external HDD. Renaming, moving, etc.pp., nothing actually displays unless on hits F5, or re-navigates to the very folder one had been a second before.

I contacted GPsoft on another issue (bug) some time back, twice, and they did not respond at all - which I find rather impolite considering the money I paid and the infrequency of short support questions (bugs usually) I e-mail to them.

Any ideas? Anyone who has external usb ntfs drives attached to a xp system (and uses hibernation) and has no problems?

Thanks for everyone who is interested in solving this.



  • "solves" the problem for some time (don't know if it consistently solves the problem every time applied): restarting DOpus (including exiting tray icon)

  • causes the problem, but does not reliably cause the problem: unplugging the usb drive without using save remove, then plugging back in. did not always cause the problem.


Have you tried the FAQ on this issue? What results do you get from the debug mode?

What was the other issue that you reported and need help with?

don't know what you mean by "other issue".

debug mode: there is no output. i.e. i reproduced the problem, nothing appeared.


You said: I contacted GPsoft on another issue (bug) some time back, twice

Did you see any output for changes made to other paths (e.g. C:), or literally no output at all?

I find it takes a few changes before any start to be output in the debug window so the part of the FAQ about triggering some changes on C:\ (or some other drive where you know everything works okay) before testing the USB drive is important.

ah, i see what you mean by "other issue". i found workarounds for all of them... I don't feel like mentioning them now. A minor one was that a plus sign occurs when one drags a file onto a tab, even when the file is to be moved. A request of mine also was never put into practice even though it's a feature of windows explorer. I beliebe DOpus should have all features that windows explorer has. It's full row selection in the folder tree. very annoying with short folder names.


after 10 operation on c:, i still do not get any output at all in the debug window.