GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Remember exact folder settings, columns etc


#1

Hi, I want when I reopen a folder, no matter how I open it (everything, autohotkey, opus, doubleclick desktop, taskbar etc) to retain its settings, columns and sorting. Its not possible to achieve it on my own. I have played with the settings but in the end the columns reverted, especially at the settings, prefs, launching opus>default lister, I have tried all options.

So for example I have a folder somewhere in C:\ called "New Music". I want sub-folders in this folder to be sorted by date created but the files inside the subfolders to be sorted by name. At the end of the day the columns and sorting have been messed up. Please guide me, thanks!


#2

Save > For This Folder & Subfolders in the Folder Options dialog is how you create the folder format.

If the format is not being used in specific situations, we need to know what those situations are in order to make suggestions.

Remember to close existing windows and open fresh ones when testing folder formats, to avoid confusion caused by cached temporary changes.

Use the tooltip on the format lock (but do not click on the format lock) to see where the current format is coming from.

The Folder Formats: Quick Guide and Detailed Guide at the top of the FAQs are worth reading if you have not looked at them already.


#3

[quote="leo"]Save > For This Folder & Subfolders in the Folder Options dialog is how you create the folder format.

[/quote]

thanks for your reply, I have used this option countless times already, in the faq it may work but in my system it doesn't.

it could be something wrong with my settings, lets go to my example above:

so what I have done many times is

  • open folder "new music"
  • click menu folder > folder options > set sorting by name (as I want the files listed inside the subfolders)

I then check that everything is saved and working ok, then I visit again the folder "new music" to change the sorting only for this folder "by date created" and I save only for the current folder and not the subfolders. However when I visit a music subfolder the sorting is messed up again to creation date.


#4

well if I am doing it correctly I may have to reinstall to reset all settings...


#5

If you want a folder format which affects only folders below a certain folder, without affecting the folder itself, then you need to use a wildcard format.

Go to Preferences / Folders / Formats, click the icon above the list for creating new formats, choose the wildcard option, and enter C:\New Music* (or whatever the real path is, with * on the end) and define what you want for it.

You'll probably already have a non-wildcard format for C:\New Music in Preferences. Edit that to make sure it's how you want that folder to be, and make sure this option is turned off for it (that checkbox is the only difference between choosing "for this folder" and "for this folder + all subfolders" when saving via the Folder Options dialog):


#6

thanks but still cannot do it, I didn't understand your reply exactly, from what I understand in the path formats there should be 2 paths with the "new music" folder, one without the wildcard (that should contain the format for the subfolders) and one with the wild card that should contain the locked format for my parent folder. Please look at the image shortcuts to tell me where I am wrong


#7

It's the other way around.

The "use as the default folder format for all sub-folders" checkbox is on, as well. It should be off for both formats.