Rename process pop-up hangs at 1st rename

After selecting files and click on Rename below pop-up shows up and 'hangs' i.e. nothing happens.

When I close the pop-up and click on the Rename button again, everything goes fine.
So, it is the 'first' time only.

=


FWIW: details of the "Rename" button.

=

TIA

What does your Preferences / File Operations / Progress Indicators page have set?

Does it only happen with a lot of files and/or on a particular drive or folder? (Is it a slow drive? Or maybe a HDD that has gone to sleep and needs to spin-up the first time it is used again?)

Very sorry for the late reply.

It has been set as per below

=

It seems the number of files is not relevant: it happens with 1 of 10 of whatever number.
The 'simple' solution is just to click [Cancel] and then just do it again. Works fine then.
It happens with fist start and to make it more complex -it happens randomly.

=

Strange, I haven't been able to reproduce that at all.

Is anyone else reading this seeing the same thing, or anything similar?

I know, it is an old thing. For me it is not solved. As said, one way or the other, when starting the rename the pop-up hangs.
When closing and doing the same action again, everything is fine.
I need to think of the before starting.

This morning I could not close the pop-up.

=

FWIW, checked some processes, not sure if they can serve any purposes.

The only thing I can think of is to try with the default Rename button/command, which is slightly different to your one:

Rename ADVANCED @nodeselect

If you stop seeing the problem with that, then it might give us a lead to investigate. So far it's still not something we've seen or had any similar reports on, which makes it more unexplained since renaming is something lots of people (us included) do a lot.

I am using F2 key that is supposed to do this:

rename INLINE=single ADVANCED PRESET=Snagit-Counter @nodeselect Rename REGEXP PATTERN "(.+?)-[0-9 -]+.(jpg|png)" TO \1\\\0

Then again, it is regularly, but not reproducable, regretfully so.

=

That's very different to what was shown in the original post.

Do you only get the problem with that, and not the command from the original post?

What is the Snagit-Counter preset?

the snagit-preset reads as follow:

find: SnagIt-
replace: -[#]-
seq numbering tagged.

All screencaptures I take are named : SnagIt-.png
I am then selecting a bunch of captures, hit F2, provide a name and the files are renamed with seq.nbr added and thereafter stored in a folder named after the filename.
Works absolutely fine. Except for these odd, occassional, 'hangs' that cannot be reproduced.
One thing I did notice though is that in most of the cases it happens after either launching Opus the very first time, say, after pc boot, or
launching Opus after nót having used it for a while.
Maybe it is solved when installing v11 one day.

Anyway, forget it Leo, I was merely hoping the screenshots would shed some light on this tiny, tiny mystery. :slight_smile:

Many thanks sofar.

Does the problem happen with the button/command in your first post (Rename PRESET=findrep ADVANCED)?

Or with the multi-line button/command you posted yesterday (rename INLINE=single ...)?

Or does it happen with both?

Leo, very sorry for the late reply. Didn't have the time to get back on this and test it again.
Last few tries went fine. Will get back case it happens again.