Renaming file or folder causes temporary duplicate to appear

Does this happen only in library folders (e.g. the Documents library)?

If so, it usually means something has added the same path to the library twice somehow.

(We are not sure how this happens, as Windows won't normally allow it to be done at all. That also makes it difficult for us to change Opus to cope with the invalid situation, as we do not know any way to create it on our own machines.)

You can fix that by right-clicking the library, choosing properties, and then checking if any folders (full paths, not just names) are listed twice. If they are, remove one of the duplicates.

Thanx like usual for the lightning-quick reply. You are correct that it only occurs in the libraries. However, when I right click on Library I don't get an option of properties. All I get are: Open in Directory Opus, Restore Default Libraries, Copy, and New Library. Here is what my tree structure looks like, but it is the same as on my machine that works ok. tree

Each item is duplicated and I can click on either one to view the files. However, do note that the icon preceding the two version of documents or of music etc. is different. This is how it has always looked on my machines, even in win7.

BUT wait - the problem just resolved!! I had previously rebooted my computer since reboots solve so many problems and it had no effect. But in the last hour I just got an update on a McAfee component and that required a reboot. Now the problem is gone. The tree structure still looks the same.

So ok for now, but I would appreciate your thoughts.


It has now been two weeks and what I notice is this. On the win10 (professional) PC that had the dupe-file name and dupe-folder name, problem, I find that it continues to happen from time to time. Sometimes if I close Opus and reopen it the problem goes away. Sometimes on boot up it is not present. And, I have also noticed it on my Surface GO that has win10 Home edition. It only occurred there once or twice, not nearly as regularly as on my win 10 professional version.

Is there the possibility that this is a bug in Opus? Has anyone else reported it?

We don't have any similar reports that weren't due to duplicate folders in the libraries.

If you can't tight click a library to access its Properties dialog then something is definitely wrong. Is the same true in File Explorer? Can you access the library properties from anywhere?

Sorry to keep troubling you on this intermittent problem. I may be misunderstanding something. I have created a word doc, but it looks like I cannot attach it, so I am copying it into this post. I contains multiple screen shots to hopefully clearly demonstrate my folder set up and questions.


Let me send you more screen shots. Perhaps I am misunderstanding something. Below is my tree structure as seen in Opus.
Here is my tree structure as seen in Explorer. As you can see it does not show the duplication of Documents as seen in Opus.

And for one more piece of info here is the Opus folder structure for my User name on this machine, a91rqzz, i.e. in the path C:\users\a91rqzz.

You told me to right click “Libraries” and choosing properties. I am not sure if you meant to click on Libraries on the heading Documents. Here is what I seen in the various cases.

Right click on Libraries


Right click on the first entry of Documents.

Right click on second entry of Documents.

On problem that I cannot demonstrate right now is what happens when the duplicate files names and folder names appear. As I said Opus is intermittently working correctly, i.e. not duplicating the file and folder names, or NOT working correctly, i.e. duplicating the file and folder names. I have been unable to determine a pattern. When there is a problem it sometimes just goes away with time, or often I can fix it by closing all instances of Opus and restarting it.

Does what I sent you suggest I have my folders set up incorrectly? I have another win10 machine (not a corporate one, with win10 home edition) and the folder structure seems to be the same.

Your wisdom is appreciated.


Right click on the first entry of Documents.

That looks correct.

It might be worth running the debugging steps shown here, making a log of what happens when the problem occurs, and another log at a time when the problem is not happening, to compare the two:

That may reveal something unusual/unexpected about the change events which are being generated on your system.

Sounds like you want me to use the DebugView tool. I will try that, but first, the link for "Fully Exit Opus" does not work. I think I know how to exit, but I would like to check that. Can you fix that link?

I've updated the post to link directly to the page's new URL.

The old URL does work but sometimes you have to click Refresh for it to load properly, for some reason. It seems to be a bug in Discourse and how it handles redirection URLs.

Here is an update. Problem still occurs intermittently, but most of the time. Here is what I have done so far.
I accessed the link on "changes to folders are not being detected."

I fully exited Opus.
I verified that no_external-change_notify was set to False.
I opened Windows Explorer and look at the file tree while simultaneously viewing it in Opus. Opus duplicated the files or folders until I hit F5. Explorer behaved correctly; it did not duplicate.
The drive as you know is not a network drive, NAS device, or NTFS junction.
As I said above it only occurs on folders in Libraries.
I have downloaded DebugView but before I ran it I tried one more thing.

I have just installed a second SSD on this PC and it is now my D Drive. In the root on D drive I created a folder called Documents. I then So my tree under Libraries now looks like this.

Files and folders in Documents have the duplication problem. Files and folders in Documents (D:) work fine.
I am planning to move all my data to D and leave programs on C. Since I only have the problem in Libraries I should be ok. I will keep an eye on this and get back to you.

I am still curious about the problem. Any new ideas, or would my next step have to be running debug?

Thank you.3

Please run the debug. It should only take a short time to do.

I ran the debug file. See attached. I changed the Opus settings as instructed before running it. As soon as I opened debug, it started accumulating lines of data before I did a thing in Opus. I guess you will have to search to find the Opus results.

Here is what I did in Opus. In one folders in the Documents directory I changed a file name. When I did the file name appeared twice. I then changed the file name back. It still appeared twice. I hit F5 and it cleared up. I did this a second time for another folder.

I goofed and save the file as a log file. I now see it had to be txt file. So I have just changed the extension. Can you just change it back at your end, or do you need me to do this again?

Two other things to note. When I booted the PC yesterday it was not exhibiting the duplication problem. I let it sit over night, did not reboot, and when used this morning the duplication problem was occurring.

This is a corporate PC with a bunch of security on it including encryption and McAfee. However, the last corporate PC I had (6 months ago) was set up the same way, also Win10 and 64 bit, and did not have this problem with Opus.

Also, as I noted above, I have very occasionally seen this problem on my Microsoft SurfaceGo with Win10 Home edition and that only runs the MS Defender security.

W0207582.txt (396.2 KB)
Thank you.

Am I right that this is the sequence of events? This is based on what the log file is showing:

  • Rename the folder Documents\_Word Files\HCP to HCPs
  • Both HCP and HCPs now appear until F5/refresh

Is that what you did & saw, or am I looking at something incidental and not the right data in the log?

Could you post a screenshot showing how the duplicate folder/file appears when it happens?

When it happens, turning on the Full Path column might also shed some light on what is happening (or may not, but it's worth a try).

Not exactly what you said. I turned on full path (nice option, I like it) and retried. Actually, please excuse me but I tried another folder this time. At first it replicated the problem. I then went back to the folder shown above and it worked fine, i.e. no problem. I then tried 5 other folders in the Documents directory and they all worked fine. I went back to the original one and it then worked fine too. Phooey. Very intermittent. But here is what happens.

This is what a folder looks like before I touch a thing.

Now I change the name on the NAL folder to "NAL new name" and here is what you see, two identical folders.

Now I press F5 and you get this. The duplicate file disappears.

This happens on files and file folders, but unfortunately intermittently.

Do you want me to try this again next time it happens and capture images and debug together? Unfortunately Snagit does not seem to run while Debug is running so I would first have to do the process to capture images and then turn on Debug and do it again for debugging.


So what did happen?

I need to know what was done in the log file that you've sent, so I know which filenames and actions I'm looking for.

The log file has 3200 lines and a lot of actions within it. I need to know which actions to focus on.

Sorry about that. I think I have learned how to better use the debug program. I quickly turned it on, did my changes, and turned it off. I tried to turn all non-essential programs off on my PC. This file only has 312 lines.
W0207582.txt (36.4 KB)

So here is where I began. See image.

I then clicked on Accept.doc to change its name. Once I do, two copies of it appear in the directory, instead of just one with the new name.

Then I press F5, and the duplicate disappears.

Let me remind you that I have done this with File Explorer open on one screen and Opus on the other. File Explorer behaves fine, i.e. the file name changes and no duplication occurs.

Let me also remind you that the problem is intermittent and it also does not occur in the Documents directory on my D drive that I have included in the Library Documents folder (see prior replies).

Sorry to be troubling you with this pesky problem. Let me know if there is anything else you would like me to do.

Here is some more info, but please do read my reply above as well. I realized that instead of changing a file name in Opus and watching it in Opus and in File Ex, I could change it in File Explorer and then watch it in both programs. The results are interesting.

Here is the debug file.
HCP change made in File Exp.txt (26.4 KB)

Here is the snagged image.

The image shows Opus on the left and File Ex on the right. I changed the name of a file called HCP. In File Ex you will see that the file's name is changed as I had intended. In Opus you will see the changed file name "HCP change" is shown but the prior name "HCP" also appears as well. Once I press F5 the situation resolves and "HCP" disappears. I tried to capture all this for you in the debug file.

Again, these problems are intermittent and I have been unable to determine what causes Opus to mess up and then what causes it to work ok again.


I'm at a complete loss, to be honest. The library setup looks normal enough, and the log entries show a normal simple rename happening with the expected paths in both cases:

dopus: Change ren_old  on C:\Users\a91rqzz\Documents\_Word Files\CAOHC\ACCEPT.DOC
dopus: Change ren_new  on C:\Users\a91rqzz\Documents\_Word Files\CAOHC\ACCEPTs.DOC
dopus: Change ren_old  on C:\Users\a91rqzz\Documents\_Word Files\HCP
dopus: Change ren_new  on C:\Users\a91rqzz\Documents\_Word Files\HCP change

It might be worth trying with Preferences / Miscellaneous / Advanced [Troubleshooting]: shellchange_debug turned on as well, in case something is generating spurious shell-change events, but I would not expect there to be any. (A quick test on my machine shows there shouldn't be any, at least, but something could be triggering them, perhaps.)

Increasing Preferences / Miscellaneous / Advanced [Troubleshooting]: notify_max_time and notify_min_items to 100 or more is worth a quick try. (No need to re-do the logging with those. Just see if they make a difference to the outcome.)

Well phooey. I wish there was an award for stumping Leo :slight_smile: but ...

I changed the max and min times to 100 and no effect.

However, here is more info. It occurred to me that copying an updated file into folder where the earlier version exists is where I first noted the problem. Opus asks if you want to update it. I say yes, and then the folder appears to contain two copies of the updated file, until of course I press F5. See examples that follow.

I have Opus open so you can see the Folder tree and two directories. You will note I have the same file in both the Documents folder and in the E-A-RCal folder. I first dragged it with the mouse from EARCal to Documents and it copied just fine. It only appeared once. But then I copied it from Documents back to EARCal and now it duplicates.
Here is the image and the debug file of the operations.

Opus Copy file duplication, only opus open.txt (21.0 KB)

And here is another png that might provide a clue. I change the name of the folder HCP to HCPs in the directory on the right and it showed up as a duplicate, but in the folder tree to the left it worked properly. So too, it worked fine in File Explorer.

Does this give anymore clues?

I still can't think of what would have caused that, based on the logs and other info which rule out the possibilities I could think of.

Were you already planning to move everything to the D drive where it wasn't happening? If you're still planning to, I would do that and then see if that keeps the problem from coming back.

I will be doing that in the next week or so and let you know. Thank you for your efforts.
I will also check it out when Opus is next updated. Speaking of which would you think and uninstall/reinstall might be helpful if the problem continues on D drive?