Renaming files and focus problem

Hi everyone

I am currently on DOpus 12.6 x64 on Windows 7.

Sometimes, in a lister, when I rename a file and hit "Enter", the focus is automatically put on the next file in the lister, and sometimes, it stays on the same file. I don't know why I have 2 different behaviors.

When I take pictures in voyages, I then rename those I keep. And I have a bunch of renaming presets which helps me gain a lot of time (with buttons shortcuts in toolbars in listers). So, if I apply preset A then preset B on the same picture, I want the focus to keep on the same file, until I choose to go to the next.
And I don't understand why sometimes it is like this, and sometimes not.

Yesterday night, my lister worked "correctly" (after renaming, the focus kept on the same file, so I could apply another preset, then another preset, to rename a part of the file).
This morning, after renaming, the focus is going always on the next file. So I have to go back a file after each click on a button (preset renaming shortcut).

I usually work in Thumbnails view, Viewer pane opened, and one lister.

I would appreciate to understand this behavior, and how to choose which one to force !


Does it depend on which presets are used, or in which order?

No, it seems to depend on the lister itself.
It is possible I have closed my lister yesterday and re-opened it this morning.

For information, one of my button executes these commands :

Rename PRESET="Ajouter Virgule-Espace"

Here is what I have just done.

I have completely exited DOpus and restarted it.
I open a lister.
I go to the photos directory.
I display my toolbar (Right click in toolbars > Toolbars > click on my Photo Management toolbar).
I select a photo (currently in Details mode, dual directory)
I click on a button to rename the current file

==> The NEXT file in then focused automatically.

I am trying to recreate the behavior where the focus remains on the current file...
I will post if I succeed.

What does the "Ajouter Virgule-Espace" preset look like? Does it include a rename script?

Also, is the file selection changing, or just the file with focus?

It looks like this screenshot.

I have also tried to play with the option "Deselect files used in functions" and trying to put the @nodeselect before or after the RENAME command, in uppercase or lowercase, but it does not change the behavior.

I forgot to respond to your second question :

When no file is selected, the buttons for renaming are grayed out. So, when I click on my "rename button", it becomes grey immediately. So I would say that the file is deselected.

The focus (light rectangle around the file) is on the next file, and if I press the space bar, then, the next file is selected, and the buttons are clickable again (but on the next file).

It sounds like the @nodeselect in the button is not working for some reason. The rename preset looks normal enough so I don't think it is that (at least not on its own).

Could you take a couple of screenshots of the main window/lister showing the files and selection before and after clicking the button? Maybe that will show a detail that I have not thought of.

Here are 2 screenshots : before and after clicking on the first file. The effect is to add a "comma + space" after the name of the current selected file (and before its extension).
We can see that the selection is lost, and that the focus is set to the second file.